Litespeed update PHP timezoneDB extension(s)

WebJIVE

Well-Known Member
Sep 30, 2007
105
15
68
Following this thread for when LS gets this fixed.
 

Duplika

Well-Known Member
Feb 26, 2005
87
12
158
Buenos Aires, Argentina
cPanel Access Level
Root Administrator
Twitter
Still no fix available.
One client alerted that now, LiteSpeed requests to install php56-devel or 71 to fix this (even though the mentioned versions are not even installed on EasyApache).

I guess we should wait for LiteSpeed to properly rewrite their timezone detection script.
 

AzeDK

Well-Known Member
Jul 14, 2011
50
25
143
cPanel Access Level
Root Administrator
This is what we use to solve the issue:

wget https://litespeedtech.com/packages/cpanel/buildtimezone_ea4.tar.gz
tar -xzvf buildtimezone_ea4.tar.gz
chmod a+x *.sh
./buildtimezone_ea4_clean.sh 5.4
./buildtimezone_ea4_clean.sh 5.5
./buildtimezone_ea4_clean.sh 5.6
./buildtimezone_ea4_clean.sh 7.0
./buildtimezone_ea4_clean.sh 7.1
./buildtimezone_ea4_clean.sh 7.2
./buildtimezone_ea4_clean.sh 7.3
./buildtimezone_ea4_clean.sh 7.4
./buildtimezone_ea4_clean.sh 8.0
 

Keith007

Active Member
Mar 30, 2013
31
9
58
cPanel Access Level
Root Administrator
Hi,
Im having the same issue but only on one server

EA4 PHP 80 Success! TimezoneDB is latest version!
version.pm did not return a true value.

Any one know a quick fix

Regards

Keith
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,497
1,968
363
cPanel Access Level
Root Administrator
I could have phrased that better for sure! Is Litespeed itself also updated? Have you tried the fix from this post?