Portaile84

Registered
Jan 7, 2012
1
0
51
cPanel Access Level
Root Administrator
Hi guru :)
I need support if possible :)

I bought a VPS hosting with cPanel WHM, activated, with domain, activated etc.

I configured all ftp account and mysql database with user allowing all mysql privileges.

But I have a problem:

Normal queries are executed correctly (I have installed mysqli support) but not LOAD DATA INFILE queries.

If I execute this I have this error:

Access denied for user 'xxxxxxxxxx'@'localhost' (using password: YES)

I check mysql client version and it is MySQL client: 4.1.22.
Into my localhost pc, where I create websites, I have 5.0.51a version.

I need support to know how I can update MySQL client version into 5.0.51a or nex stable version.

Into VPS I currently have MySQL 5.1 installed.

Can anyone help me?

I have all right access into my VPS ;)
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
The MySQL client for PHPMyAdmin is not the same as the MySQL version at all. It does show 4.1.22 as that's the PHPMyAdmin version itself not the MySQL version you are using.

Next, please review this post about LOAD DATA INFILE an why this isn't going to work in PHPMyAdmin by default:

Mysql LOAD DATA INFILE