The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LOAD DATA LOCAL broken in PhpMyAdmin after update

Discussion in 'Database Discussions' started by maverick, Jun 25, 2004.

  1. maverick

    maverick Well-Known Member

    Joined:
    Jan 6, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Hi everyone,

    After updating to cPanel 9.4.1-R55, the upload data function in PhpMyAdmin (LOAD DATA LOCAL) no longer functions. It now returns the error:
    "#1148 - The used command is not allowed with this MySQL version"

    This function has always worked in the past and only the two servers where we updated cPanel now exhibit the problem.

    I have checked that the "local-file" option is enabled in MySQL (it definitely is) and the LOAD DATA LOCAL file works without error via a Perl script on the same server. The problem appears to be with cPanel's PHP. We had to run the the /scripts/makecpphp script in order to get Horde working after the update. I suspect that this part of the update is what caused the problem, though I haven't proven that as yet.

    I have gone to some lengths to solve the problem myself, but haven't had any success. Although I have submitted a ticket already, if anybody has discovered a fix/workaround for this issue, we'd love to hear it.

    Thanks.

    Regards,
    Mav.
     
  2. maverick

    maverick Well-Known Member

    Joined:
    Jan 6, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    cPanel support have provided a solution for this (thanks!).

    Here was their response:

    "I have confirmed this to be a bug with the makecpphp script. I submitted a bug report on your behalf on our bugzilla interface found here:

    http://bugzilla.cpanel.net/show_bug.cgi?id=802

    The fix for this issue is simple and you can implement it before the final fix goes through. Just edit /scripts/makecpphp where in the configure statements you see --with-mysql change it to:

    --with-mysql=/usr

    Save it, leaving everything else untouched. Then just run /scripts/makecpphp again."

    Mav.
     
  3. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    We're amazed that it's been about three weeks since you've posted this and the makecpphp file still hasn't been fixed! Did they close out your ticket?
     
  4. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Not only that but the fix does not work.
     
  5. maverick

    maverick Well-Known Member

    Joined:
    Jan 6, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    jsteel: Yeah they closed the support ticket - but the bugzilla report is still open (see link above). I was surprised too that something so blatantly broken wouldn't have been remedied right away.

    Myacen: The fix did work for us (across all servers). Just to clarify, the $conf part should now look like this:

    $conf = "./configure --enable-static " .
    "--enable-mbstring --enable-mbstr-enc-trans " .
    "--enable-mbregex --with-zlib " .
    "--with-imap $IMAPFLAGS --enable-ftp --with-gettext --with-xml " .
    "--enable-track-vars --enable-sockets --with-mysql=/usr " .
    "$PGSQL " .
    "--with-config-file-path=/usr/local/cpanel/3rdparty/etc " .
    "--prefix=/usr/local/cpanel/3rdparty";

    Mav.
     
  6. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    hi, the fix dont work for us, any other advice? we are in WHM 9.4.0 cPanel 9.4.1-C133
    RedHat Enterprise 3 i686 - WHM X v3.1.0
     
  7. webJ

    webJ Active Member

    Joined:
    Apr 9, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1

    It's not working for us either.

    RedHat 7.3 - WHM 9.4.0 cPanel 9.4.1-S65
     
  8. webJ

    webJ Active Member

    Joined:
    Apr 9, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I cannot believe that more people aren't saying anything about this.
     
  9. 0utlier

    0utlier Well-Known Member

    Joined:
    Aug 7, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    We had this problem, but recompiled php with --with-mysql=/usr rather than the standard
    --with-mysql and that fixed it for us. I imagine that advice works for most. I don't know why it's not working for you. I'm sorry.
     
  10. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    --with-mysql=/usr works on all our servers. :)
     
  11. webJ

    webJ Active Member

    Joined:
    Apr 9, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Looks like it's tied now 3 to 3 ;)
     
  12. Faldran

    Faldran Well-Known Member

    Joined:
    May 28, 2002
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    That fix worked on ours as well.
     
  13. zentity

    zentity Well-Known Member

    Joined:
    Jun 16, 2004
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    http://nz2.php.net/mysql

    --with-mysql=/dir (--with-mysql=/usr) is required in order to use the LOAD DATA LOCAL command with php.

    Read also what the mysql folks have to say here : http://dev.mysql.com/doc/mysql/en/LOAD_DATA_LOCAL.html
     
    #13 zentity, Aug 6, 2004
    Last edited: Aug 6, 2004
  14. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    This error suddenly returned for us in 9.7.7

    Strange...
     
  15. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
  16. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    I am having this issue as well.

    Reviewing makecpphp I see...


    $MYSQL='--with-mysql';
    if (-e "/usr/local/bin/mysql") {
    $MYSQL='--with-mysql=/usr/local';
    }
    if (-e "/usr/bin/mysql") {
    $MYSQL='--with-mysql=/usr';
    }


    do I change all three values of --with-myql=?


    ? or is this already correct as is.
     
  17. cyon

    cyon Well-Known Member
    PartnerNOC

    Joined:
    Jan 15, 2003
    Messages:
    320
    Likes Received:
    0
    Trophy Points:
    16
    That's a good question, could need a bit help with this, too.
     
  18. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    bump
    bump
     
  19. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    Did you try doing /scripts/updatenow ?

    After doing that /scripts/makecpphp did not need any modification at all for us on several servers.
     
  20. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    I have not tested it since the new phpmyadmin interface in the latest stable builds but have not received any complaints since.
     
Loading...

Share This Page