The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

load imap module problem

Discussion in 'General Discussion' started by czdmm, Jun 20, 2008.

  1. czdmm

    czdmm Member

    Joined:
    Jun 19, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I have just rebuilt Apache through cpanel, how come configure command doesn't include --with-imap even I have included imap module.

    The below is the phpinfo():

    Configure Command './configure' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-sockets' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-gd' '--with-gettext' '--with-jpeg-dir=/usr' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pic' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr' '--without-iconv'


    Loaded Modules core mod_access mod_auth mod_include mod_log_config mod_logio mod_env mod_expires mod_headers mod_setenvif mod_proxy proxy_connect proxy_ftp proxy_http mod_ssl prefork http_core mod_mime mod_status mod_autoindex mod_asis mod_info mod_suexec mod_cgi mod_negotiation mod_dir mod_imap mod_actions mod_userdir mod_alias mod_rewrite mod_so mod_auth_passthrough mod_bwlimited mod_fpcgid mod_php5


    How can I configure the php configure command line.

    cheers
     
  2. DevilSun

    DevilSun Member

    Joined:
    Apr 26, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    You should re-compile apache because according to the information your provided, IMAP is not installed on the server.
    you should re-compile it like the following:

    './configure' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-sockets' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-gd' '--with-gettext' '--with-jpeg-dir=/usr' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pic' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr' '--without-iconv' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr'
     
Loading...

Share This Page