Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Local Mail Exchanger with remote MX

Discussion in 'E-mail Discussions' started by TiagoFreitas, May 31, 2017.

  1. TiagoFreitas

    TiagoFreitas Registered

    Joined:
    May 31, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Portugal
    cPanel Access Level:
    Website Owner
    Hello,

    We are trying to configure our e-mail in this way:

    - MX is set to Google Suite where e-mails initially go
    - If the user exists in Google, it stays there
    - If the user doesn't exist, it gets routed to another server (cpanel). This is at a hosting company and we only have access to cpanel.
    - When the email gets to the cpanel server, it gets rejected with the error:
    550 SMTP AUTH is required for message submission on port 587

    Cpanel configurations:
    - Routing is set to Automatically Detect Configuration : Local Mail Exchanger
    - MX is Google servers
    We had to ask the hosting company to make this configuration because cpanel was automatically changing the routing to Remote Mail Exchanger when MX was set to Google, which we don't want. We want it to accept e-mails to local users, the only difference is they will be always coming from Google's servers using a routing rule and not through MX.

    We think we are getting the error because cpanel is not considering the domain as local so user is remote. It should be local. But the e-mail account is created in cpanel.

    Thanks in advance.

    This is the full error in the delivery event:
    Code:
    Event: rejected
    User: -remote-
    Domain:
    Sender: someusr@gmail.com
    Sent Time: May 31, 2017 9:55:09 AM
    Sender Host: mail-vk0-f71.google.com
    Sender IP: 209.85.xxx.xx
    Authentication: unauthorized
    Spam Score: 0
    Recipient: someusr@example.com
    Delivery User: volter
    Delivery Domain: example.com
    Delivered To:
    Router: reject
    Transport: **rejected**
    Out Time: May 31, 2017 9:55:09 AM
    ID: 1dFzPm-0009TY-IM
    Delivery Host: mail-vk0-f71.google.com
    Delivery IP: 209.85.xxx.xx
    Size: 0 bytes
    Result: SMTP AUTH is required for message submission on port 587
    
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. TiagoFreitas

    TiagoFreitas Registered

    Joined:
    May 31, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Portugal
    cPanel Access Level:
    Website Owner
    I don't need per-email-account.
    I just needed that cpanel ignores the MX records when receiving mail, and behaving normally. MX is to be used by those sending e-mails.
    If it receives an e-mail for a local domain, it should accept it (if the user exists) or give an error if the user doesn't exist. As simple as that..

    There is really no workaround for this? Google officially supports it and I'm sure many people would like to use it because google for bussiness is expensive when you have many accounts and it makes sense to have some of them on another server.

    Thanks.
     
  4. TiagoFreitas

    TiagoFreitas Registered

    Joined:
    May 31, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Portugal
    cPanel Access Level:
    Website Owner
    There used to be an option in MX editor:
    "Always accept mail locally even if the primary mx does not point to this server."

    Exim (/etc/localdomains) problem after recent update

    So there is no way anymore? And no way to add an exception to EXIM?

    This also used to work according to these instructions:

    theemaillaundry.com/knowledgebase/adding-mx-records-in-cpanel/

    Thanks
     
    #4 TiagoFreitas, Jun 1, 2017
    Last edited by a moderator: Jun 1, 2017
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  6. TiagoFreitas

    TiagoFreitas Registered

    Joined:
    May 31, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Portugal
    cPanel Access Level:
    Website Owner
    It turned out it works, I was just connecting to the wrong port.

    Port 25 accepts mail with SSL/TLS without authentication for local users.
    Port 587 only accepts with authentication.

    I didn't know this and got lucky because I tried with another server I have and found out qmail-smpt works the same way.

    Thanks
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm happy to see the issue is now solved. Thank you for updating us with the outcome.
     
Loading...

Share This Page