Localhost issue causing SPAM

Sindibad

Registered
Dec 20, 2021
3
0
1
USA
cPanel Access Level
Root Administrator
Hi Cpanel Members,

I'm about to give up while looking for a solution to this strange issue,

We have created a server with Contabo and we use WHM /CPANEL ..We send test emails to our gmail and it goes to the inbox ,So far everything looks normal .

Our company is for fire protection and emails and phones are used in high priority .. but last week one of our clients noticed that emails went to spam ..

So we try to investigate what caused this problem. We have checked all records DKIM - SPF DMARC- PTR and it looks normal the hostname is set correctly. We have also set it through SSH .. but the inbox is not fixed .. IP is clean and the server is created less than one a month ago , we don't send bulk emails and checked the email logs and nothing is shady , I have hired a freelancer working remotely on our server and he agreed that everything is well set except the host file the localhost 4 was missing we have add it and tested the webmail and luckily it works emails again are sent to inbox .. the next day our email flagged as spam...


We have performed a test on mail tester and it shows 10/10 fully authenticated

We have another server from another company we compared all parameters on this server with the other one which send to inbox and make it the same , restart the EXIM and everything , What we notice while reading the header is this parameter :

Received: from localhost ([127.0.0.1]:53934 and we think this is what caused this problem . whilst the other server which send to inbox has: Received: from [::1] (port=38292


a screenshot for the email header is attached :

HOSTS

Code:
127.0.0.1               localhost localhost.localdomain localhost4 localhost4.localdomain4
::1             localhost localhost.localdomain localhost6 localhost6.localdomain6


66.94.XX.XX         server.XXXXX.com server

We really appreciate your help

Regards,
 

Attachments

quietFinn

Well-Known Member
Feb 4, 2006
1,653
325
438
Finland
cPanel Access Level
Root Administrator
Received: from localhost ([127.0.0.1]:53934 and we think this is what caused this problem . whilst the other server which send to inbox has: Received: from [::1] (port=38292
127.0.0.1 and ::1 are the same, the 1st is IPv4 address and the second is IPv6 address, so I don't think that can cause any problems. :rolleyes:
 
  • Like
Reactions: cPanelAnthony