The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Log files not backing up after processing

Discussion in 'General Discussion' started by benjamink, Mar 20, 2016.

  1. benjamink

    benjamink Registered

    Joined:
    Mar 20, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Hey everyone - I hope I'm posting in the right place. I tried searching the forums for this "bug", but didn't really know what to search for and everything I could find seems to be about something else...

    I seem to be having an issue with the archived logs not being backed up when processed for stats?!? If that makes no sense, sorry ... let me try this:

    1) I can see the visits in my current raw log file. I visit a site on my phone, boom - it's there.
    2) I process the log via the CLI (it's also set to run every 24 hours) ... /scripts/runweblogs
    3) It processes just fine (log below) but, the archive from raw stats does not show any new visits (just visits from over a week ago, the 10th)

    If I visit the site again, re-run the logs, the data from before is gone.

    I got this because when I tried to view AWStats it had zero data to show.
    Oh, btw - the AWStats page does not show the log information from a week ago (the only logs I have in the archive).

    I have zero idea where to look for this - I'm guessing all the log files between the 10th and now are lost?

    Bandwidth is showing visits, the "Current Visitor" also works and shows information.
    It's like as if everything is deleted when running the stats.

    I do have cPanel set to delete the log files after processing, but to archive in the home directory. It's just like as if it's not updating the archive anymore...

    Is it a permissions issue? Help!! Thanks :)

    Here is some output from the CLI command:

    Code:
    [2016-03-21 12:13:26 +1000] [sepxferlog]
    [2016-03-21 12:13:26 +1000] [sepxferlog] complete
    [2016-03-21 12:13:26 +1000] Processing example...
    [2016-03-21 12:13:26 +1000] Run Logs domain: example.com.au BW Limit: unlimited Domains: []
    info [safeapacherestart] Restart elapsed seconds: 1
    [2016-03-21 12:13:47 +1000] Process bandwidth for example
    info [safeapacherestart] Restart elapsed seconds: 1
    [2016-03-21 12:14:08 +1000] Disk Usage for example on /dev/vda1 (1332/0)
    [2016-03-21 12:14:08 +1000] Archive Status for exmple: 1
    [2016-03-21 12:14:08 +1000] Processing example, fork() required to drop privs with (domains:1 domains)
    [2016-03-21 12:14:08 +1000] [setuid] example (uid=1006,gid=1006)
    [2016-03-21 12:14:08 +1000] [dologs] execute: awstats for user: example, log: /usr/local/apache/domlogs/example.com.au.bkup.
    [2016-03-21 12:14:09 +1000] Create/Update database for config "/home/example/tmp/awstats/awstats.example.com.au.conf" by AWStats version 7.4 (build 20140726)
    [2016-03-21 12:14:09 +1000] From data in log file "/usr/local/apache/domlogs/example.com.au.bkup"...
    [2016-03-21 12:14:09 +1000] Phase 1 : First bypass old records, searching new record...
    [2016-03-21 12:14:09 +1000] Direct access to last remembered record is out of file.
    [2016-03-21 12:14:09 +1000] So searching it from beginning of log file...
    [2016-03-21 12:14:09 +1000] Phase 2 : Now process new records (Flush history on disk after 20000 hosts)...
    [2016-03-21 12:14:09 +1000] Jumped lines in file: 0
    [2016-03-21 12:14:09 +1000] Parsed lines in file: 6
    [2016-03-21 12:14:09 +1000]  Found 0 dropped records,
    [2016-03-21 12:14:09 +1000]  Found 0 comments,
    [2016-03-21 12:14:09 +1000]  Found 0 blank records,
    [2016-03-21 12:14:09 +1000]  Found 0 corrupted records,
    [2016-03-21 12:14:09 +1000]  Found 0 old records,
    [2016-03-21 12:14:09 +1000]  Found 6 new qualified records.
    [2016-03-21 12:14:09 +1000] Complete
    
    --
    
    
    One thing: this is for all accounts/domains on the server, it seems to only process the latest information keeping zero historical data. Have I just configured this wrong (on another cPanel server, it's behaving fine?).
     
    #1 benjamink, Mar 20, 2016
    Last edited by a moderator: Mar 20, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. benjamink

    benjamink Registered

    Joined:
    Mar 20, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Awesome, done!
    Ticket # 7498025.

    Fingers crossed for a good outcome :)
     
Loading...

Share This Page