The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LogLevel Settings Issue in v58

Discussion in 'EasyApache' started by sehh, Aug 7, 2016.

  1. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    Hello,

    I noticed a minor bug in the new version 58. Under:
    Home > Service Configuration > Apache Configuration > Global Configuration

    There is a new setting, LogLevel, which has two minor errors. The first error is in the PCI recommendation which is "none", but "none" is not an acceptable option per Apache 2.4 spec. The second error is in the description after you click on the question mark, it says that values are in order of decreasing significance, but in fact they are in alphabetical order, thus breaking the... significance.

    Screenshot attached.

    Thank you!
     

    Attached Files:

  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    64
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    Thanks for the report! I've replicated what you're seeing. We have those listed out properly in the backend of the code, but I believe the UI is putting those in alphabetical order. I think we'll remove that text that advises it's in a certain order.

    Also, in regards to the PCI message, I believe that when it says 'None', it means there are no PCI recommendations for that specific directive, not that "None" is the PCI recommendation for that directive.

    I think we can easily clean up the messaging on this area pretty quickly. I've opened case EA-4978 to address these changes.
     
  3. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    Thank you Jacob for the quick response!

    I think the PCI recommendation for "none", is confusing to me, because the "File ETag" option also says "none" but its actually possible to select "none" from the drop-down list. Just a minor ambiguity really, nothing of importance. Only an issue to my OCD brain :)
     
Loading...

Share This Page