The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logos not showing in phpinfo()

Discussion in 'Security' started by Astral God, Jul 28, 2012.

  1. Astral God

    Astral God Well-Known Member

    Joined:
    Sep 27, 2010
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    Hi.

    A little problem: when i call phpinfo(), the PHP logo and other logos (Zend...) are not showing.

    I'm using Stable tier, mod_security and CSF/LFD.

    Any help ?
    Thanks.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is anything else not working besides the logos?

    Does the account have its own php.ini file under suPHP? Compare the php.ini file to the global one if that's the case:

    Code:
    diff /usr/local/lib/php.ini /home/username/public_html/php.ini
     
  3. Astral God

    Astral God Well-Known Member

    Joined:
    Sep 27, 2010
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    I don't know if anything else is not working.

    There is only one php.ini, the main one, users php.ini function has been disabled.

    Thanks.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is anything displaying in the Apache or account-level error log?

    Code:
    tail -fn0 /usr/local/apache/logs/error_log
    tail -fn0 /home/username/public_html/error_log
    Please replace username with the cPanel username. Use the same path as the phpinfo page you are trying to load (again, only if there's an account level error log in that folder, though).

    Thanks!
     
  5. Astral God

    Astral God Well-Known Member

    Joined:
    Sep 27, 2010
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    It seems tha mod_security is blocking this:

    Also check https://www.atomicorp.com/forums/viewtopic.php?f=3&t=5057

    Solved disabling this rule, and it is safe to do, that if expose_php is set to Off (see PHP Easter Egg )
     
Loading...

Share This Page