Steve Kemp

Member
Jul 29, 2014
16
5
53
Mount Clear, Victoria, Australia, Australia
cPanel Access Level
DataCenter Provider
Just back from the holidays and ive noted that on all of our servers the Logview addon is no longer working

Internal Server Error

500

No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi): The subprocess reported error number 2 when it ended.

ther error log returned:

Code:
Can't locate whmlib.pm in @INC (you may need to install the whmlib module) (@INC contains: /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/5.24.1/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/5.24.1 /opt/cpanel/perl5/524/site_lib/x86_64-linux-64int /opt/cpanel/perl5/524/site_lib /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi) at /usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi line 13.
BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi line 13.
[2017-01-09 09:36:41 +1100] info [whostmgrd] Internal Server Error: "GET /cpsess9786624287/cgi/logview/lview.cgi HTTP/1.1" 500 No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi): The subprocess reported error number 2 when it ended.
Can't locate whmlib.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /usr/local/cpanel /usr/local/cpanel/whostmgr/docroot/cgi) at /usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi line 13.
BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi line 13.
[2017-01-09 09:39:42 +1100] info [whostmgrd] Internal Server Error: "GET /cpsess9786624287/cgi/logview/lview.cgi HTTP/1.1" 500 No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/logview/lview.cgi): The subprocess reported error number 2 when it ended.
any ideas whats causing this and how to fix as we find this plugin very handy and are missing it already...
 
Last edited by a moderator:
  • Like
Reactions: shetuadda

xisn

Well-Known Member
Dec 4, 2004
136
5
168
cPanel Access Level
Root Administrator
Not sure how it is unsafe? I have deleted Joomla just in case and using a different html site. My site does not send email or use iframes... Either way, files are safe.
 
  • Like
Reactions: Infopro

EonHost

Registered
Mar 6, 2018
2
0
1
Odessa. Ukraine
cPanel Access Level
Root Administrator
It seems that this user xisn is no longer active on this site, and has not been here in a very long time (almost a year).
I know from past experience that the url of the logview app has changed quite often as well.
The current site itself contains one of the most early versions (still in beta), as someone else already pointed out.
It's a shame, because this was a really great addon.
I am trying to patch some things together myself to get this working for new installs with that version 5.5.
Let's see how it goes.