The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logwatch filling up /tmp

Discussion in 'General Discussion' started by Solokron, May 7, 2007.

  1. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    I just starting having an issue of a logwatch directory being created in /tmp and filling it to full capacity recently. Anyone else encounter this? Any resolutions?
     
  2. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    same problem, updated yesterday and filled up tmp
     
  3. NetBlaster

    NetBlaster Member

    Joined:
    Jun 12, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    I'm having the same problem but I'm not sure if its logwatch. My server has been running smooth until 5/2. I did upgrade to version 11 but not until 5/4. I thought it might correct the problem but nada.

    Here is the thread I've been on but not really getting a cause or long term solution.

    http://forums.cpanel.net/showthread.php?t=65697&highlight=tmp+full


    Ron...
     
  4. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Thanx Ron, but in my case im on 10.9.0-RELEASE_10737 and the filling up directory is the logwatch one, i just nuked that directory to keep the server running.

    New ideas are welcome and also a fix from cpanel :)
     
  5. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  6. NetBlaster

    NetBlaster Member

    Joined:
    Jun 12, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    It happened to me on that version as well. I upgraded just to see if it would fix it.

    Not sure if this has anything to do with it but my spamd keeps failing. Before it fails I have three services run up to 15 - 20% -- cpbandwd, syslogd and kjournald. I think they run like that until the spamd fails and then drop down when spamd does its auto restart. Then it starts all over again.

    My problem my be off topic but it sure seem coincidental.

    Ron...
     
  7. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
  8. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    Just a question to discard things....i have rvskin spam solution installed on these servers, wondering if you have this rvsking solution installed also to see if that could be the cause?, in fact only the servers with the rvsking spam solution is where we are having this problem.
     
  9. nnnnoooo

    nnnnoooo BANNED

    Joined:
    Mar 24, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    No RVskin here but same problem.
    Note that it only occurred once on my system. Nuked the directory and it hasn't reoccurred.

    The spamd issue however is continuous. I've removed it for the timebeing.
     
  10. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    16
    ouch, i did post it in the wrong thread...sorry...this was about the spamd problem.
     
  11. shopcentar

    shopcentar Well-Known Member
    PartnerNOC

    Joined:
    Jul 10, 2004
    Messages:
    55
    Likes Received:
    1
    Trophy Points:
    8
    same thing we have on our server, also we have must remove spamdconf and SpamAssassin Spam Filter.

    version
    WHM 10.8.0 cPanel 10.9.0-S9966
    RedHat Enterprise 3 i686 - WHM X v3.1.0

    bye, SC
     
  12. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    We have just recovered from a full /tmp directory as, also filled with files in /tmp/logrotate. Apache would not restart; gave segmentation faults. The server is running WHM 10.8.0 cPanel 10.9.0-R118. The last upcp was run two days ago.

    Not is this case it seems. The editing /etc/cron.daily/logrotate references /var/spool/logrotate/tmp as tmpdir. But still the files went to /tmp :confused:
     
  13. nnnnoooo

    nnnnoooo BANNED

    Joined:
    Mar 24, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Any further thoughts on this?
    It's still plaguing our systems.
     
  14. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    What are the contents of the logwatch directory? If it is your mail log check the contents. I suspect a spamassassin issue in which case you may want to check the following thread:

    http://forums.cpanel.net/showthread.php?t=65838

     
  15. Stefaans

    Stefaans Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    451
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Vancouver, Canada
    We had this problem with /tmp filling up on two servers after the SpamAssassin 3.2 upgrade. We fixed the problem on the others before it could occur. The following worked for us without any glitches:

    1) Upgrade to Perl 5.8.8 to get rid of the bulk of the error in /var/log/maillog
    Code:
    cd /usr/src
    wget http://layer2.cpanel.net/perl588installer.tar.gz
    tar -xzf perl588installer.tar.gz
    cd perl588installer
    ./install
    
    2) Delete the SARE_ADULT rule (if you have it installed) to get rid of the last, and most annoying error of the bunch:
    Code:
    rm /etc/mail/spamassassin/70_sare_adult.cf
    After doing all of this, you should check the /var/log/maillog any remaining SpamAssassin problems:
    Code:
    tail -f /var/log/maillog
    I hope this helps nnnnoooo ;)
     
Loading...
Similar Threads - Logwatch filling tmp
  1. Leriss
    Replies:
    4
    Views:
    540

Share This Page