The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logwatch - old version?

Discussion in 'cPanel Developers' started by DavidR, Dec 27, 2004.

  1. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    The logwatch installed with my RH 9 VPS is version 4.3.1, which is quite old. Reinstalling from RPM in WHM installs the same version. Before I charge on and install the latest version from logwatch.org, is there a reason cPanel wants to use this older version?

    I'm still not familiar with what software is controlled or managed by cPanel (is there a list somewhere?), so I have no desire to break it. Thanks.

    David
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Using the latest noarch rpm from logwatch.org will work just fine. You're only getting the old was as that was the last version that RH released before the EOL of RH9.
     
  3. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Thank you. That makes knowing what software is handled buy cPanel and what isn't even more important I guess. Could YUM be used with an exception list in the conf to update these (software that is out of date)? Or is there a master list of software that cPanel controls and should not be touched, but the rest if fair game? I'm not experienced enough to know what needs to be updated by myself :(.
     
  4. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Oh wait, you mean that the RPM Package Installer in WHM is installing from an old depository of programs? Yikes! What's up with that? Can it be changed?

    David
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, it's old in that it's no longer supported since RH9 was EOL'd some time ago. There's nothing you can do about that other than to look at some of the RH9 support services, or preferrably to upgrade to a support OS. The latter being the best solution.
     
  6. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    You know how sometimes you try to wrap your brain around something and just can't because you don't have all the pieces? Well I feel like that right now so please bear with me :eek:.

    I understand that RH9 is EOL. I also understood (or assume) that Yum can be used to update it (am I wrong?). When I was using a server with DirectAdmin for the control panel, I used Yum to update everything but that was after configuring yum.conf to ignore certain things that were DirectAdmin specific. Now, cPanel is much more mysterious to me and I understand (assume) that it is quite intangled with the rest of the server software. I am hesitant to just run Yum Update without knowing what will break cPanel if it is updated outside the backend scripts. Does this make sense?

    If I understand you correctly, those RPM's in WHM under Software will never be upgraded because RH9 is EOL. So why doesn't cPanel just use Yum for updates anyway (or can it?).

    I'm very confused. Is there a yum.conf with exclusions that I can see that will work with cPanel?

    David
     
  7. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Yum is just a package manager, much like up2date and apt-get. It does not create the packages automatically with updates. It just grabs the rpms requested from whatever place you tell it to in the config. Redhat 9 is EOL which means End Of Life. Redhat no longer release updates for the product. Fedoralegacy.org has taken up the challenge to release updates for redhat 9 however they have not really kept to a routine. They have not had enough volunteers to help keep the project kicking. With a stock redhat 9, even if you have applied all the patches released by fedoralegacy, you will still be out of date. There is another solution, though i can not vouch for them, progeny ( search google ). This might be your best solution if you are unable to migrate the system to a new OS. There are howto's available for migrating redhat 9 to CentOS, I believe i posted one to this forum. Use it at your own risk, especially on a live system. I've done quite a few machines without a problem. CentOS is RedHat's Enterprise linux OS rebuilt from the source they release for their now paid OS. There is no upgrade path to RH enterprise, so if you need the support from Redhat, you will need to get a new machine with RHEL and then migrate all the clients to that new system. Otherwise your probably best going with CentOS.

    Have you configured yum to work with fedoralegacy ? This is something you must do on your own, there is no hand holding for such administration tasks by the cpanel software itself.
     
  8. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Thank you. I've found a couple of scripts /scripts/checkyum & safeyum. The former looks like it is supposed to modify the yum.conf for cPanel usage but I can't get it to run (run /scripts/checkyum comes up with command not found - any ideas?). I am going to try to manually modify the yum.conf using what I can find in that script about exclusions, and I found instructions for configuring it to fedoralegacy. I'm also looking into Progeny, which is certainly cheap enough but I need to find out more about it.

    Any additional suggestions are welcome.

    David
     
  9. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Those yum scripts do not configure the yum.conf to work with fedoralegacy, it just configures yum to work more safely with cpanel. For instance it excludes httpd, mod_ssl, etc. from updates as these are all installed from source on cpanel machines.

    To set up yum for fedoralegacy ( includes yum installation instructions incase its not installed ):
    http://www.fedoralegacy.org/docs/yum-rh9.php
     
  10. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Would Fedora 2 be significantly better? I am limited to this or RH9 in my current situation.

    David
     
  11. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Personally, I'd avoid any fedora core OS as a server platform like the plague.
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would too. It's fine if you're into application development and the like, but it is not very stable when it comes to an environment you need reliability, dependability and support for (i.e. web hosting) and only has a 6 month lifecycle. Whereas RHE (and the CentOS spin-off) at least offers support and a lifetime over 5+ years.
     
  13. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    Well I'm limited at the moment. Perhaps I can upgrade later in 2005. At the moment I am still in the early stages so at least Fedora 2 contains more recent versions of everything. I sincerely appreciate the advice though. I learned quite a bit today actually, so it's not all bad ;). I'm going to take a look at CentOS when I get a chance.

    David
     
Loading...
Similar Threads - Logwatch old version
  1. ethical
    Replies:
    3
    Views:
    124

Share This Page