The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

long user name error

Discussion in 'General Discussion' started by celliott, Oct 17, 2006.

  1. celliott

    celliott Well-Known Member

    Joined:
    Jan 2, 2006
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United Kingdom
    Check that the account's folder in /home was also correctly renamed to the new username.
     
  2. tmallardi

    tmallardi Well-Known Member

    Joined:
    Jan 18, 2005
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    El Paso, TX
    I imported an account from an older server. The account's username was longer than 8 characters. Everything seemd to work okay though, so I left well enough alone.

    Now I discovered that accounts with long user names, don't work well in certain situations. Specificaly, when adding a script with Fantastico. So I went into cPanel and shortened the username to 8 characters. Although cPanel said everything was changed succesfully, the website is no longer available via the Internet.

    Is there perhaps a configuration file somewhere that needs to be manualy updated?

    Thank you,
    Tim
     
  3. tmallardi

    tmallardi Well-Known Member

    Joined:
    Jan 18, 2005
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    El Paso, TX
    Yep, it does appear to have been renamed correctly. The /public_html folder is owned by "nobody", and the rest of the folders appear to be owned by the newly shortened username.
     
  4. tmallardi

    tmallardi Well-Known Member

    Joined:
    Jan 18, 2005
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    El Paso, TX
    One other thing I verified...I can indeed browse to the site using the following

    IP Address/~new_username

    Still can no longer browser to the domain_name.com though.
     
  5. tmallardi

    tmallardi Well-Known Member

    Joined:
    Jan 18, 2005
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    El Paso, TX
    *Resolved*

    Ran the following script:
    /scripts/updateuserdomains

    Restarted httpd
    /etc/rc.d/init.d/httpd restart
     
  6. rstockins

    rstockins Registered

    Joined:
    Dec 5, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Sorry that username is too long. MAX is 8 letters

    Hi,

    $whm->createacct($domain, $user, $pass, $plan);

    if ($response !~ /wwwacct creation finished/) {
    logError("WARNING:There was a problem setting up the account. $response");
    }

    <table width=100%><tr><td>Sorry that username is too long. MAX is 8 letters
    </td><td width=30><img src=/icons/error.gif></td></tr></table>

    <br /><b>Account Creation Complete!!!</b><br />

    Question: how can i adjust this limit ?

    Richard
     
Loading...

Share This Page