lose database (mysql) connections during backup

warren0728

Member
Dec 23, 2004
7
0
151
i have two sites using databases (wordpress) sites....

every time i backup using whm's backup, as soon as the backup process starts neither site can connect to their databases. after the backup procedure i have to restart mysql and then the sites work fine....is there any way to keep mysql running during or after the backup so these sites can stay online?

Apache 1.3.42
mysql 4.1.22
php 4.4.9

thanks in advance,
ww : )
 

eth00

Well-Known Member
PartnerNOC
Mar 30, 2003
721
1
168
NC
cPanel Access Level
Root Administrator
Is the server overloading when this is happening or is it just going down anyways?


Does MySQL actually crash or is it still running, just not responding?
 

warren0728

Member
Dec 23, 2004
7
0
151
i just upgraded the server to the latest version of cpanel/whm and last night it backed up and did not lose connection....hoping the upgrade fixed the problem!
 

warren0728

Member
Dec 23, 2004
7
0
151
well 2 or 3 backups worked fine and now it is doing it again....this is really frustrating....as soon as i restart mysql everything works fine again....anyone else have this same problem and have any ideas....it's crazy that it started working and then all of a sudden quit again....

i have also noticed that if i add a new account (domain) to my server the same thing happens and i have to restart mysql to get my database driven (wordpress and joomla) sites running again....any help would be appreciated!

thoughts?
ww
 
Last edited:

warren0728

Member
Dec 23, 2004
7
0
151
bump....still having the same problem....i did check the MySQL error log and did not see any errors that would suspend operations....this is driving me crazy :-(
 

contractorsan

Registered
Sep 10, 2010
1
0
51
I'm experiencing the same issue, but I think it might be tied to some configuration settings within my database. If I find it's on my end, I'll post the fix, otherwise I'll keep my eye on this thread incase it is indeed on cPanel's side.

Thanks! :)