The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lost Email Accounts and Cannot Add Them

Discussion in 'E-mail Discussions' started by checks2you, Jun 9, 2004.

  1. checks2you

    checks2you Registered

    Joined:
    Jan 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi =)

    Something happened yesterday morning that caused me to lose 5-6 email accounts in Cpanel. I am currently unable to add the accounts back into Cpanel.

    It looks like everything goes through when attempting to add an account but when returning to Add/Remove Accounts the new email accounts are not being listed - even with screen refreshes...

    Just to test I went into WHM and created a new dummy account on the same server and then went into that dummy account's Cpanel and was able to add email accounts at will with no problems, so it seems that the issue is tied to a single user account.

    I did the Apache & Cpanel Updates which may or may not have caused this, but since then Exim has been going crazy and crashing.

    I am using WHM and Cpanel 9.2.0 Redhat 9.

    Any ideas?

    Thanks in advance!
     
  2. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    I had something similar with FTP accounts; turned out to be the account owner created a new package that had 0 FTP accounts. Then he couldn't add any new FTP accounts.

    At least worth looking at....
     
  3. checks2you

    checks2you Registered

    Joined:
    Jan 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi ladydi711 :D

    Thanks for the fast reply! It is a dedicated server that I have a reseller account for.

    I did check the package details in WHM after reading something here in the forum about leaving the max email accounts blank no longer meant "unlimited". I do not know if that is true or not, but I did set it to 999 and the problem persists... :confused:

    What is really confusing is that I can add another account from scratch and I have no problems adding email accounts...

    Anyone else have any ideas? I know there are some pretty sharp people here. :D
     
  4. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    Worst case scenario create a full backup, delete and recreate account, then apply backup.
     
  5. checks2you

    checks2you Registered

    Joined:
    Jan 7, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the input B12Org! :D

    I may have found and fixed the problem - so far all is just peachy...

    I got to thinking about what ladydi711 mentioned about quotas. While the email accounts were set to 999 max accounts and weren't visible in Cpanel - I could see them when I FTP'd into the server.

    Whatever it was deleted my /etc/users folder; passwd; quota; and shadow files...

    So I went back in a created the new /etc/users folder etc. and was able to add email accounts, send and recieve emails.

    So the only issue is what caused this in the first place??
    :confused:

    Thanks to all for your input - hopefully this post is odd enough to help someone else should they have a similar issue... :D
     
Loading...

Share This Page