Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Lost modules after Apache update

Discussion in 'EasyApache' started by handreach, Feb 16, 2007.

  1. handreach

    handreach Member

    Jul 11, 2004
    Likes Received:
    Trophy Points:
    A problem has happened to me since a while ago: after updating Apache with "PHP suEXEC Support" turned on in Cpanel, it just throws error. I tried easyapache script as well in shell window, and the same error happened. After looking at the error message, I realized that some Apache modules just disappeared (like bandwidth module, big byte module etc.), and it only happens if I select "PHP suEXEC Support".

    Since I do need PHP suEXEC support, my compromise right now is to run Apache update first with "PHP suEXEC Support" turned on, and after it's done, I copy those missing module files back and then start the Apache httpd daemon.

    I am glad that my hacking works so far, but I can't help wondering why it should be so. Anyone knows it?:rolleyes:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice