The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lost remote MySQL server after adding IP range

Discussion in 'Database Discussions' started by tgv, Dec 11, 2012.

  1. tgv

    tgv Member

    Joined:
    May 29, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi colleagues,

    Something weird happened today. I'm no network expert so would greatly appreciate if someone explained what is wrong with my setup. I understand it's not really db issue so -- mods please feel free to move it where it fits.

    We've a WHM (CentOS) machine running on xx.yy.zz.71 and a remote MySQL server (Ubuntu) running on xx.yy.zz.100.

    I've spent a while setting up remote MySql, adding ssh keys etc., and it worked fine for many months until I was told that there's actually a range of IP's assigned to the first machine: xx.yy.zz.64/27

    So I went to WHM's "Add a New IP Address" screen and added this whole range, exactly as xx.yy.zz.64/27. In a moment I got a complaint from the client about all sites running on the xx.yy.zz.71 failing to connect to db.

    I then tried to ping xx.yy.zz.100 from the WHM machine, from different interfaces, including xx.yy.zz.71, to no avail (host unreachable). xx.yy.zz.71 pinged fine from xx.yy.zz.100 at the same time.

    Then I went to WHM's "Show/Delete IPs" screen and removed all freshly added IPs one by one, monitoring pings in the next window, and when I removed all new IPs and left only xx.yy.zz.71, ping started to work (and MySQL as well)!

    Two questions,
    - what's wrong??
    - how do I add new IPs without ruining the link to remote MySQL server?

    Thanks a lot in advance
     
Loading...

Share This Page