The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

lost while reading message data (header)

Discussion in 'E-mail Discussions' started by testtubebaby, Aug 6, 2007.

  1. testtubebaby

    testtubebaby Member

    Joined:
    Jul 28, 2007
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I am unable to recieve emails from a mailserver .. keep getting the error......



    2007-08-06 18:30:46 SMTP connection from <remote mail servername> [x.x.x.x]:2149 I=[y.y.y.y]:25 lost while reading message data (header)



    x.x.x.x = remote mail server IP
    y.y.y.y = my mailserverIP


    Spamassasin is turned of for the domain that needs to recieve ....mail scanne runinstalled .... exim reset to defaults,... x.x.x.x added to /etc/rblwhitelist ... sender verify callout disabled.


    Please advise.


    Thanks.
     
  2. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
    apologies to bump this old thread, but since my search turned vein, i am updating an old ticket,

    I am also seeing this in my logs and the customer complaining about not being able to connect to our server to send mails, I have NO hard firewall or any such restrictions but i see this in the exim_mainlog

    list matching forced to fail: failed to find host name for

    What could this mean ...any one ?
     
  3. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Yes, we need to know what this means too please in /var/log/exim-mainlog:

    Also seeing

    the IP of which is a hosting client who cannot send emails out
     
  4. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
  5. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Yes, reverse dns is in place for the server IP, and has been for years.
     
  6. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello,

    Is this issue resolved?
     
  7. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    OK, there does seem to be a known issue with Orange Internet connections currently where 3rd pary SMTP connections are being blocked. Orange have confirmed this by telephone.

    Our current workaround is to simply ask the clients (assuming they are indeed with Orange) to use smtp.orangehome.co.uk as the outgoing mail server and make sure they use port 25 and disable 'server requires authentication'.

    Hope this helps anyone.
     
  8. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello,

    If this is the issue, can't you try 26,465 ( common alternative ports for smtp which should be opened in the server ) for mail purposes.
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Varada,

    Port 26 is not opened by default on cPanel machines unless the following has been set in WHM > Service Manager:

    Here you would have had to place 26 into the field and then click "Save" to change the setting. Now, port 587 is also another alternate port you could add in that area rather than 26, since many ISPs block port 26 as well (but do not block 587).

    465 is the TLS on connect port, so that one is opened by default. It's a secure port for exim actually.

    You can see which ports are opened for mail and being used by running the following (I've used port 465 as the example):

    Code:
    [root@itchy:~] # egrep 465 /etc/exim.conf
    daemon_smtp_ports = 25 : 465
    tls_on_connect_ports = 465
    
    [root@itchy:~] # lsof -i :465
    COMMAND   PID     USER   FD   TYPE    DEVICE SIZE NODE NAME
    exim    16160 mailnull    5u  IPv6 198945326       TCP *:smtps (LISTEN)
    exim    16160 mailnull    6u  IPv4 198945327       TCP *:smtps (LISTEN)
    If you run the same commands to check port 26 and/or 587, you will not receive a return unless you've set one of those as the alternate exim port in WHM's Service Manager as previously mentioned.

    Thanks!
     
  10. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello Tristan,

    Yes, I was exactly mentioning to set the port 26 in Service Manager. Some ISP's blocks port 25 and now a days most of the hosts opens an extra port for smtp to resolve this issue.

    Thanks.
     
Loading...

Share This Page