The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lowest numbered MX record points to local host

Discussion in 'E-mail Discussions' started by Wallaby, Jan 12, 2011.

  1. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    I've searched high and low here and elsewhere and cannot find a solution which works for my problem.

    Accounts on CPanel Server 1 cannot send email to accounts on CPanel Server 2. The error shown by Exim on CPanel Server 1 when trying to send is:

    Lowest numbered MX record points to local host

    I've checked that the domains for the accounts on CPanel Server 2 are in /etc/localdomains -- they are.

    I can send mail from other (non-CPanel) servers to accounts on CPanel Server 2 with no problem.

    I've restarted Exim on both servers, I've rebooted CPanel Server 2, no change.

    This seems to have become an issue recently (last few months?), as the same procedures requiring these emails to be sent have been in place for a long time.

    Any ideas at all?
     
  2. usman43

    usman43 Member

    Joined:
    May 16, 2008
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Make sure a duplicate entry is not present in /etc/remotedomains
     
  3. jordan.robison

    jordan.robison Registered

    Joined:
    Jan 21, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Also the solution if you get this error: just go to your WHM, then "Edit DNS Zone". You will want to select the domain you want to fix by clicking "Edit" and then in "Save". That's all. Clicking "Save", will automatically put the entry in the localdomains.
     
  4. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    Both /etc/localdomains and /etc/remotedomains are correct -- this is *not* the issue.

    Anyone else?
     
  5. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    OK, just for anyone else who comes across this issue, I found the problem.

    Let's say Server 1 was trying to send mail to domain.com on Server 2. The MX record for domain.com was, let's say, server2mx.company.com.

    The A record for server2mx.company.com in the DNS (a CPanel DNS only cluster) was incorrect -- it was pointing to the IP for server 1.

    So Exim on Server 1 was giving me the correct error message; it was really saying "The mx for domain.com says I handle mail for domain.com, but I've checked and I don't!".
     
  6. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Always always always double check your MX record settings first when having a mail problem. :)
     
  7. mitgib

    mitgib Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2006
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    awk -F ':' '{ print $1 }' /etc/userdomains >> /etc/localdomains

    That was a real quick and dirty fix I used for this problem
     

Share This Page