The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lowest numbered MX record points to local host

Discussion in 'E-mail Discussions' started by FRCorey, Jun 7, 2012.

  1. FRCorey

    FRCorey Member

    Joined:
    Feb 1, 2012
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Just a FYI if you get the error message

    Lowest numbered MX record points to local host

    After making a DNS change, go back into the zone editor and change your serial. For some reason cPanel does not play nice with the serial and you have to manually increment it to not cause an issue. For instance tonight it was still using a serial from may 31st.
     
  2. MilesWeb

    MilesWeb Well-Known Member
    PartnerNOC

    Joined:
    May 23, 2012
    Messages:
    174
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    @FRCorey Thanks for the share.

    I have had this issue when entry for domain was missing in /etc/localdomains. Added it manually & that fixed it.
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Manually adding an entry to /etc/localdomains likely won't stick long-term. Typically, it isn't in /etc/localdomains because it is in /etc/remotedomains and has the MX set to remote in /var/cpanel/users/username file where username is the cPanel username. This means the domain should be removed from /etc/remotedomains file, /var/cpanel/users/username file changed to point it to local rather than remote, and these two scripts run:

    Code:
    /usr/local/cpanel/scripts/updateuserdomains
    /usr/local/cpanel/scripts/mailperm
     
  4. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Tristan,

    Thanks. This is great information. I've been battling this every once in a while and did the same thing the poster above did.. added it manually. It will work for a few weeks/months and then remove it again. Hopefully this solution will make this work permanently.

    I do have one question though... You mention that in the /var/cpanel/users/username file, it has the MX set to remote and it should be set to local. I just looked at a customers /var/cpanel/users/username file and it has nothing about MX records or the word remote or local anywhere in there...

    Is this still the case for this situation??


     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    It is typically the case, yes. If you aren't seeing that in /var/cpanel/users/username file for any MX at all:

    Code:
    grep -i mx /var/cpanel/users/username
    Then you might want to add the entry instead in the file somewhere toward the bottom. It should look like the following:

    MXCHECK-domain.com=0

    Here replace domain.com with the domain name.

    Thanks!
     
  6. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    So then, is MXCHECK-domain.com=0
    local, and =1 remote ??

    Or does it simply mean =0 (do not do any MXCHECK?)

    Thanks again


     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    =0 means local in this instance. =remote is for remote. You can toggle the setting in WHM > DNS Functions > Edit a DNS zone area for the mail settings at the bottom to see it change in /var/cpanel/users/username file to see what does what for settings for that field.
     
  8. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Tristan,

    So, final question... Is this MXCHECK line a requirement in the /var/cpanel/users/username file?? Because I wrote a small script to check to see if this line is present and I'm finding that almost all of my customers don't have this line (either for local or remote). I can modify my script to add it, if missing but is that going to do more harm then good? Or is that going to make sure I don't run into problems if a user changes MX record data in their DNS?
     

Share This Page