The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lowest numbered MX record points to local host

Discussion in 'General Discussion' started by Heritz, Dec 1, 2007.

  1. Heritz

    Heritz Well-Known Member

    Joined:
    Aug 12, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Hello all,

    I have a dedicated server with WHM 11.2.0 and CentOS 4.5. Lately, all the emails cannot be delivered because of the following error in the exim_rejectlog:

    lowest numbered MX record points to local host

    For instance:

    2007-11-25 04:34:26 H=s3.computrabajo.co.uk [69.59.28.133] F=<apache@s3.computrabajo.co.uk> temporarily rejected RCPT <gerencia@jobe65.com>: lowest numbered MX record points to local host

    Do you guys have any idea about why could be this happening? This happens for all the domains. Every time I restart the DNS service (BIND) the email starts to work perfectly, but after a few days, it starts to bounce everything.

    Thanks for your help folks! ;)
     
  2. rbalaji

    rbalaji Member

    Joined:
    Nov 27, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    login to WHM and go to Main >> DNS Functions >> Edit MX Entry

    set MX priority to 0 for the related domain and save.


    This will fix the mail issue.

    Thanks:)
     
  3. Heritz

    Heritz Well-Known Member

    Joined:
    Aug 12, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Thanks rbalaji.

    Actually all the domains in the server have priority 0 for the MX record. But the problem still happens from time to time. Everytime it happens, I just restart the DNS server and the mail starts to work again.

    Any ideas?...
     
  4. Heritz

    Heritz Well-Known Member

    Joined:
    Aug 12, 2006
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Hi all,

    Just for reference, in case someone else has the same issue:

    For some reason, when I create the accounts in my WHM 11.15.0, the file /etc/localdomains is not getting updated. That file is important for some reason for the mail delivery if the MX entry of the domain is pointing to localhost.

    So, the solution if you get this error: just go to your WHM, then "Edit DNS Zone", select the domain you want to fix, click "Edit" and then in "Save". That's all. Clicking "Save", will automatically put the entry in the localdomains. Obviously this will fix the error.

    I hope it helps, I had a really bad time trying to figure this thing out!
     
  5. andren

    andren Active Member

    Joined:
    Oct 4, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Thank you, that fixes it.
    One would think cpanel would be able to fix it...
     
  6. karlos

    karlos Member

    Joined:
    Oct 1, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    Thanks!! it works!!

    In my case WHM writes the subdomains of the account but not the main domain :confused:
     
  7. seahorse

    seahorse Well-Known Member

    Joined:
    Jul 3, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6

    even though i upgraded to the latest release version...
    i have this problem too.... not able to receive emails.

    the above solution, edit dns, then save without doing anything.. works.
     
  8. Apoc

    Apoc Active Member
    PartnerNOC

    Joined:
    Mar 4, 2003
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    DataCenter Provider
    We had this problem today too on one server of a client. What I don't understand is that cPanel doesn't have some kind of script to simply check all the domains on the server (based on cPanel's configuration) and then checks with the localdomains file to see whether it's consistent.

    Should be very easy to implement and to be honest I don't understand why it doesn't already have this by default if cPanel relies on the localdomains file for mail and such.
     
  9. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You mean like this:

    /scripts/checkalldomainsmxs

    ?
     
  10. neiderlaander

    neiderlaander Registered

    Joined:
    Jul 1, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lansing, MI
    mx record priority 0 issues

    Hello all, noob here, go easy on me :) I recently ran in to a problem with the priority record of 0 being used for an offsite MX server, and when using a priority of 0 while pointing to a non-local host the mail wouldn't work. When setting the priority to 1, the off-site mail flowed normally. I was wondering if the 0 priority ALWAYS points to localhost only? thanks....
     
  11. jiju

    jiju Registered

    Joined:
    Dec 20, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    MX-priority

    Hello,

    When you set up MX entries at the DNS, you must be aware that the lowest number has the highest priority. So if the " 0 " is pointed with the domain name itself, it uses the localhost ie the same server on which that domain is hosted. To set a domain to use an external mailbox, MX entry for the same at the DNS should be pointed with " 0 " so that it will get the highest priority. ::)
     

Share This Page