The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MacOSX (version 10.9.4) Outgoing Mail Problem

Discussion in 'E-mail Discussions' started by donlange, Feb 26, 2015.

  1. donlange

    donlange Member

    Joined:
    Jan 18, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Has anyone else experienced trouble with SMTP and MacOSX Mail while trying to communicate with their cPanel mailserver?

    While using SSL, I've tried ports 465 and 587 and my outgoing mailserver goes offline as soon as I try to send mail from MacOSX Mail. I configured the client by hand exactly the way cPanel indicated (with port 465) and then tried port 587 with the same disappointing results. Incoming mail from my cPanel server works just fine with the client configured as an IMAP account (SSL/port 993).

    cPanel says that "Authentication is required for IMAP, POP3, and SMTP"; however, I have five different selections for authentication. I've tried "Password" and "TLS client Certificate" both with ports 465 and 587 and all mail I try to send from my mail account associated to my cPanel mailserver goes right to the Outbox to sit forever.

    Again, the OS version is 10.9.4

    Thank you for your help...
    Don
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Have you tried using the AutoConfigure script to see if it sets up the email account correctly? It's available under the "Configure Email Client" section when clicking "More" in the email account list.

    Thank you.
     
  3. donlange

    donlange Member

    Joined:
    Jan 18, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes, I've already tried that on another client (MacOSX Lion which is version 10.7) and it automatically configured the email account as I did by hand with SMTP set to port 465.

    Don
     
  4. kdean

    kdean Well-Known Member

    Joined:
    Oct 19, 2012
    Messages:
    262
    Likes Received:
    12
    Trophy Points:
    18
    Location:
    Orlando, FL
    cPanel Access Level:
    Root Administrator
    Never had any Mac Mail client problems here.

    SMTP, Port 465 SSL, Authentication password (make sure your email/password is entered in the SMTP settings and not just the incoming), using the server hostname as the mail server works for me.
     
  5. donlange

    donlange Member

    Joined:
    Jan 18, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yep, should be an easy configuration. Is there a possibility the mailserver (Dovecot) is not configured properly? Or am I having problems because I don't have an SSL certificate for the domain yet? I wouldn't think the latter is relevant because the client won't send mail using port 25 without SSL either.

    Don
     
  6. kdean

    kdean Well-Known Member

    Joined:
    Oct 19, 2012
    Messages:
    262
    Likes Received:
    12
    Trophy Points:
    18
    Location:
    Orlando, FL
    cPanel Access Level:
    Root Administrator
    If you're configured your server to require SSL connections (Home »Service Configuration »Exim Configuration Manager - Security - "Require clients to connect with SSL") then that would block port 25. You said you hadn't set up an SSL certificate for the domain yet. If you mean the server hostname and you truly do not have an SSL cert setup and not even a self-signed one (which wouldn't be good in the long run), then I can see that being a problem since you wouldn't be able to connect via port 465 and if SSL is required even 587 would require a TLS secure connection. Check what you have set up at Service Configuration »Manage Service SSL Certificates. Exim and Dovecot would need SSL certs.
     
  7. donlange

    donlange Member

    Joined:
    Jan 18, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    "Require clients to connect with SSL" is set to the default which is OFF

    For Service Configuration » Manage Service SSL Certificates under certificate details I have for both Exim and Dovecot:

    self-signed, 2048 bit key size; expiration date: 01-08-16

    Can you concluded anything from this?

    Thank you,
    Don
     
    #7 donlange, Mar 1, 2015
    Last edited: Mar 2, 2015
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  9. donlange

    donlange Member

    Joined:
    Jan 18, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    OK, I'll open the support ticket:

    My Request id is: 6179863

    Thank you,

    Don
     
    #9 donlange, Mar 3, 2015
    Last edited: Mar 3, 2015
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can still open a support ticket with us. The "WHM Home » Support » Support Center" option provides you with a support access number to enter into the ticket interface if you need it.

    Thank you.
     

Share This Page