The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Macromedia Contribute and Pure-Ftp

Discussion in 'General Discussion' started by Epademic, May 8, 2006.

  1. Epademic

    Epademic Active Member

    Joined:
    Nov 21, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    I have a client who is attempting to use Macromedia contribute to edit their website however it is failing on one of the pre connection tests and i don't know why.

    The error says "contribute cannot verify your connection information" when it is carrying out the "Set permissions" test (i think)

    So i am just wondering if there are any cPanel admins out who know of any of their users that are using Contribute to edit their sites, and if so was there anything that you needed to tweak to Pure-FTP?

    Many thanks,

    James
     
  2. protocol

    protocol Well-Known Member
    PartnerNOC

    Joined:
    Apr 13, 2004
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    We have customers with Contribute on a couple of servers using pure-ftp and have not experienced any problems.

    Regards

    Will
     
  3. Epademic

    Epademic Active Member

    Joined:
    Nov 21, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    see the example in the box below where you have /public_html/ ?

    wouldn't it be something like this?

    /home/user/public_html ?
     
  5. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Also, what happens when you select the "Choose" button?
     
  6. Epademic

    Epademic Active Member

    Joined:
    Nov 21, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    I'm pretty sure "/public_html/" is correct.

    When you select the choose button it actually shows you the file structure of your ftp account as it would with any FTP program. (you previously have to enter your ftp information). You then select the public_html directory and click OK.

    It connects and performs all the required tests but fails on just one (the "set permissions" test i think)

    I have even downloaded the server checker test program from Adobe/Macromedia which reports a 100% successful test.

    http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_18932#serverchecker

    Thanks for all the suggestions.

    James
     
  7. maxime

    maxime Member

    Joined:
    Aug 13, 2001
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hi James,

    Have you managed to resolve it ?

    Thanks,

    Maxime
     
  8. Epademic

    Epademic Active Member

    Joined:
    Nov 21, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    No I did not manage to resolve this issue with Contribute. Its probably worth me looking into this again. ;)

    Are you having the same problem?

    James
     
  9. Damian

    Damian Well-Known Member

    Joined:
    Oct 1, 2001
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    8
    Just a suggestion, as I don't use contribute myself.

    Try entering:

    public_html/

    Without the leading directory slash. If the choose button shows the local FTP directories then it may be expecting a relative path to be entered.
     
  10. Epademic

    Epademic Active Member

    Joined:
    Nov 21, 2003
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the suggestion. I have not looked into this issue for sometime, but back when i was trying to resolve this issues i tried every combination i could think of to get it to connect.

    As i recall, the choose button shows the remote directory structure.

    Cheers,

    James

    PS i don't actually use Contribute myself. This was an issue a client was having
     
  11. wptechno

    wptechno Active Member

    Joined:
    Jun 10, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Has anyone figured this out? I'm running pureftp and am getting the same exact issues. There's got to be an answer to this.
     
  12. wptechno

    wptechno Active Member

    Joined:
    Jun 10, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Here's a link from the contribute website on the issue:

    http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?catid=302&threadid=1146845

    Here's the possible solution text portion I extracted. Let me know if anyone knows how to run these commands taken from the contribute website. Also I can't find these locations on my server.. what might the alternate paths be?

    ---------------------------------------------------------------

    Try to create a symbolic link to /var/www/html directory


    a) Telnet to your linux machine.
    b) cmd$ pwd
    /home/username/
    c) Create a symbolic link to /var/www/html/site1 directory
    <site1> is the directory of your website.
    cmd$ ln -s /var/www/html/site1 mySite
    - This command will create a sybolic link named "mySite" pointing to the "Website Root of your site".
    d) cmd$ ls -l
    - Verify Symbolic link is created
    e) cmd$ cd mySite
    - Change your directory to "mySite". Verify it will allow the user to move to that particular directory /var/www/html/site1 for which you have all permissions (Typically you can have 776) permissions for that directory.

    Now Enter the website url as - http://servername/mySite/
    - Verify this Web address works fine in browser and displays your site.

    f) In contribute, Enter this Website url in connection wizard2.
    g) Enter proper FTP User id details (as used above)
    h) Now contribute should not prompt you to select the directory to which you need to connect.

    This is only related to how you configure Apache to have a symbolic link created in user home directory. This is the only way some one can access his own site on a unix machine via any FTP client or the same with Contribute.

    Hope this helps.

    Thanks
    Arun (Contribute Team)
     
  13. wptechno

    wptechno Active Member

    Joined:
    Jun 10, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Can someone help me with these instructions I've posted. The instructions don't really completely work with my server like the www/html/ path doesn't exist. I was wondering if someone might know another way to do this above.

    Also, if anyone else is using contribute on their cpanel server, let me know how you get it to work. It used to work.
     
  14. wptechno

    wptechno Active Member

    Joined:
    Jun 10, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    I've found out why contribute is not working. It's because temporary files with tmp in the filename cannot be created or accessed. Here's what the contribute admin sent to me. Please if anyone has any insight on how to allow tmp filenames to be temporarily created, please let me know.


    ---------------------------------------
    I did some tests and here’s what I found out.



    When verifying FTP connection information, Contribute uploads a temporary file inside public_html. After uploading the file, Contribute tries to access the file using the URL of your site. However, there is a setting on your server that is not allowing HTTP access to TMP files; this is the reason why Contribute is not able to verify your connection information.


    This is a URL that is pointing to a TMP file that Contribute uses for its tests.

    http://www.cinciplaywrights.org/TMP123456789.htm


    Below is a second test HTML file that is accessed via HTTP with no errors.

    http://www.cinciplaywrights.org/mmtestfile.htm

    There is a security setting on your server that prevents HTTP access to files that have “TMP” of “TEMP” prefixes on their filenames. At this point, you would need to contact your hosting company to allow HTTP access to TMP files.

    ----------------------------------

    Thanks
     
  15. mdangelo

    mdangelo Registered

    Joined:
    Jan 12, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    disable modsec, I have found contribute to cause problems that are identical while modsec is enabled...
     
  16. wptechno

    wptechno Active Member

    Joined:
    Jun 10, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    I found a fix for this without having to completely disable mod_security.. here it is:

    ------------------------------
    Reconfigure mod_security in httpd.conf for apache server so you can access tmp files via http. (this is good if you are having problems with Adobe Contribute)

    In mod_security rules Change line:
    SecFilterSelective "THE_REQUEST|ARG_VALUES" "(/dev/shm|tmp|/var/tmp|/var|wget|/home/virtual|/etc/)" deny,log

    To this:
    SecFilterSelective "THE_REQUEST|ARG_VALUES" "(/dev/shm|/var/tmp|/var|wget|/home/virtual|/etc/)" deny,log


    - we're taking out the |/tmp| so contribute can access and create TMP123456789.htm files on clients' websites.

    ------------------

    Cool.
     
  17. mdangelo

    mdangelo Registered

    Joined:
    Jan 12, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Nice find... thanks for sharing...
     

Share This Page