SOLVED Magento Admin menu icon missing

Tarak Nath

Well-Known Member
Mar 12, 2018
78
12
8
India
cPanel Access Level
Root Administrator
Hello,

We have uploaded the Magento 2.2.5 site through IP URL (temporarily) http://123.34.56.78/~user/magento but the backend admin menu icon is missing. Please find the attached screenshot. Is there any server related issue in admin backend as there is no issue in frontend.

Please help us if you can. Any suggestion should be appreciated.

Below is the server info:

[[email protected] ~]# /usr/local/cpanel/cpanel -V
78.0 (build 21)

[email protected] [/]# cat /var/cpanel/envtype
standard

[[email protected] ~]# cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core)

[[email protected] ~]# php -v
PHP 7.1.28 (cli) (built: Apr 23 2019 18:00:17) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.3.2, Copyright (c) 2002-2018, by ionCube Ltd.


Regards,
Tarak Nath
 

Attachments

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @Tarak Nath,

There are several limitations when using the Apache Mod_Userdir URL to access a website. These are documented at:

Apache mod_userdir Tweak - Version 78 Documentation - cPanel Documentation

The better approach to access a website before it's DNS resolves to your server is to modify the hosts file on your individual workstation:

How to Modify your hosts File - cPanel Knowledge Base - cPanel Documentation

Can you let me know if the issue persists when accessing the website using the method documented in the link above?

Thank you.
 

Tarak Nath

Well-Known Member
Mar 12, 2018
78
12
8
India
cPanel Access Level
Root Administrator
Hello,

We have found the main reason. There was firewall which created the issue.

For security perspective it was a policy in our firewall which is "Rewrite HTML" and "Rewrite Cookies" was enabled. We have disabled them and its working perfectly as expected.

Thank you for everything.

Please mark this thread as SOLVED.

Regards,
Tarak Nath