The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Magento needs InnoDB - is that compatible with other apps?

Discussion in 'General Discussion' started by mambovince, Apr 10, 2009.

  1. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    Hi,
    A client needs to install Magento Ecommerce
    http://www.magentocommerce.com/system-requirements
    But getting this error:
    "Database server does not support InnoDB storage engine".

    We currently have
    MySQL version 4.1.22-standard-log
    PHP version 5.2.8

    1. Cann MySQL 4.1.22 support InnoDB?

    2. Will InnoBD cause problems with other most popular apps on this server, mainly Joomla, Mambo, Wordpress?

    Appreciate your advice or experience with similar situation.

    best wishes,

    - Vince
     
  2. Zishan

    Zishan Well-Known Member

    Joined:
    Aug 6, 2005
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    0
    From MySQL 4.0 on, the InnoDB storage engine is enabled by default unless you have added skip-innodb option to your MySQL option file /etc/my.cnf.

    It won't cause any issue with other applications. InnoDB is just a storage engine i.e format in which the data is stored/maintained.
     
  3. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
  4. aegis

    aegis Well-Known Member

    Joined:
    Jul 6, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Magento at one point used to install a shortened php.ini file which caused the installer to report that InnoDB wasn't available on some servers.

    I think it only affected early v1.1.x versions but occasionally I get someone migrating from another server where it worked and hitting that bug. They stopped supplying a php.ini some time ago.
     
  5. dwykofka

    dwykofka Well-Known Member

    Joined:
    Aug 6, 2003
    Messages:
    394
    Likes Received:
    3
    Trophy Points:
    18
    I'm having a problem transferring a magento site from Mysql4 to Mysql5.

    When I do a pkgaccount I get errors like

    User_magento.checkout_agreement_store
    error : Got error 1 from storage engine
    User_magento.cms_block_store
    error : Got error 1 from storage engine
    User_magento.cms_page_store
    error : Got error 1 from storage engine
    User_magento.customer_address_entity_datetime
    error : Got error 1 from storage engine
    User_magento.customer_address_entity_decimal
    error : Incorrect information in file: './User_magento/customer_address_entity_decimal.frm'
    User_magento.customer_address_entity_int
    error : Got error 1 from storage engine
    User_magento.customer_address_entity_text
    error : Got error 1 from storage engine
    User_magento.customer_entity_datetime
    error : Got error 1 from storage engine
    User_magento.customer_entity_decimal
    error : Incorrect information in file: './User_magento/customer_entity_decimal.frm'

    After moving the package to the destination server there are lots of errors on the site.

    I really need to get this guy to one of my newer servers over the weekend so if anyone has a good method to move this site please let me know.
     
Loading...

Share This Page