"Magic number checking on storable file failed" in cPanel Account / Quota problem

SupraNet

Registered
Mar 14, 2013
2
0
1
cPanel Access Level
Root Administrator
After restarting the mySql Server yesterday, because there was a problem with it, I now get this error on one of my cPanel accounts and also the quotas do not display right anymore. Here the error that shows in the cPanel when I click on "[a fatal error or timeout occurred while processing this directive]" in the notices box:

Magic number checking on storable file failed at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/Storable.pm line 414, at /usr/local/cpanel/Cpanel/SafeStorable.pm line 69
Carp::croak('Magic number checking on storable file failed at /usr/lib/perl5/...') called at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/Storable.pm line 38
Storable::__ANON__('Magic number checking on storable file failed at /usr/lib/perl5/...') called at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/Storable.pm line 415
Storable::fd_retrieve('GLOB(0x1613b400)', 0) called at /usr/local/cpanel/Cpanel/SafeStorable.pm line 69
Cpanel::SafeStorable::fd_retrieve('GLOB(0x1613b400)') called at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 120
eval {...} called at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 120
Cpanel::CachedDataStore::loaddatastore('/home/glaslife/.cpanel/email_accounts.yaml', 0, 'HASH(0x1613b250)', 'HASH(0x16139610)') called at /usr/local/cpanel/Cpanel/API/Email.pm line 4644
Cpanel::API::Email::_managepopdbs('event', 'fetch') called at /usr/local/cpanel/Cpanel/API/Email.pm line 302
Cpanel::API::Email::list_pops_with_disk('Cpanel::Args=HASH(0x16139360)', 'Cpanel::Result=HASH(0x16139090)') called at /usr/local/cpanel/Cpanel/API.pm line 60
Cpanel::API::_execute('Email', 'list_pops_with_disk', 'HASH(0x1f38a00)') called at /usr/local/cpanel/Cpanel/API.pm line 238
Cpanel::API::wrap_deprecated('Email', 'list_pops_with_disk', 'HASH(0x1f38a00)') called at /usr/local/cpanel/Cpanel/Email.pm line 1310
Cpanel::Email::api2_listpopswithdisk('nearquotaonly', 1) called at /usr/local/cpanel/Cpanel/Api2/Exec.pm line 110
eval {...} called at /usr/local/cpanel/Cpanel/Api2/Exec.pm line 110
Cpanel::Api2::Exec::api2_exec('Email', 'listpopswithdisk', 'HASH(0x1613bbc0)', 'HASH(0x1df2ad0)') called at cpanel line 978
main::real_cpexectag('<?cp Email::listpopswithdisk([span class="warning"][strong]$LANG...') called at cpanel line 4104
main::dotag_finished_headers(0) called at cpanel line 3925
main::cpanel_parseblock('<?cp Email::listpopswithdisk([span class="warning"][strong]$LANG...') called at cpanel line 3839
main::y('GLOB(0x15c76ac0)') called at cpanel line 5144
main::run_standard_mode() called at cpanel line 766
In the WHM I get this when I run initial quota setup:

Installing Default Quota Databases......Done
Quota Mode: Linux
journaled quota support: not available with vzaquota (disabled)
Quotas have been enabled, however they may not be up to date as quotacheck has been skipped.
Reading package Customer 250MB 3000MB
No filesystems with quota detected.
Resetting quota for admin to 1000 M
No filesystems with quota detected.
Resetting quota for base to 500 M
and so on...
Somehow I guess resetting the SQL Server also messed with my quota setup? The main problem is that only one cPanel is getting the first error, and that one customer now can not receive Emails - if you send him one, you get this error message: "mailbox is full: retry timeout exceeded".

Any help would be greatly appreciated!
Thanks :cool:
 
Last edited: