Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mail delivery Error

Discussion in 'E-mail Discussion' started by hasan, Jun 18, 2005.

  1. hasan

    hasan Registered

    Joined:
    Jul 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    I've searched, but found nothing.

    One user's email is not getting delivered, the error is:

    R=virtual_user T=virtual_userdelivery defer (20): Not a directory: creating lock file hitching post /home2/***/mail/***.com/user.name/inbox.lock.cpanel.***.com.42b4a921.00002848 (euid=32023 egid=12)

    Any help is much appreciated
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Have you tried:

    /scripts/mailperm
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hasan

    hasan Registered

    Joined:
    Jul 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    re. mailperm

    Yup, but did not fix
     
  4. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    What are the ownerships on /home2/***/mail/***.com/user.name
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. hasan

    hasan Registered

    Joined:
    Jul 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    permissions

    directory 750, files 660. Its strange, as all other users on the domain are fine.
     
  6. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    I asked about ownership..check that, right settings are user.mail..check exim.conf also...local_delivery section must look like this >>

    Code:
    local_delivery:
      driver = appendfile
      delivery_date_add
      envelope_to_add
      file = "${extract{5}{:}{${lookup{$local_part}lsearch{/etc/passwd}{$value}}}}/mail/inbox"
      group = mail
      mode = 0660
      return_path_add
      user = $local_part
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #6 nickb, Jun 19, 2005
    Last edited: Jun 19, 2005
  7. hasan

    hasan Registered

    Joined:
    Jul 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    151
    Fixed. Nick you are a star, the ownership on the users' directory was messed up.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice