The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Delivery Failed (550)

Discussion in 'E-mail Discussions' started by skina, Sep 22, 2007.

  1. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I am getting the following 550 error when trying to send emails to external domains:

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    skinner@destiny-denied.co.uk
    SMTP error from remote mail server after MAIL FROM:<nobody@server.xeaura-host.co.uk> SIZE=2449:
    host mailserver.destiny-denied.co.uk [213.171.216.66]:
    550 <nobody@server.xeaura-host.co.uk>: Sender address rejected:
    Domain not found


    There is no record or account for destiny-denied.co.uk on the server.

    The server is a new VPS - there wasnt an upgrade from a previous version.

    I am also having trouble setting up private nameservers (my host is slow to respond).

    dig google.com works fine

    Version info:

    WHM 11.2.0 cPanel 11.11.0-R16983
    CENTOS Enterprise 4.5 i686 - WHM X v3.1.0

    exim -bt skinner@destiny-denied.co.uk:
    skinner@destiny-denied.co.uk
    router = lookuphost, transport = remote_smtp
    host mailserver.destiny-denied.co.uk [213.171.216.66] MX=5

    /etc/hosts:
    83.167.189.145 server.xeaura-host.co.uk server
    127.0.0.1 localhost

    /etc/resolv.conf:
    nameserver 83.167.189.134
    nameserver 83.167.189.135

    The 2 IP's above are:
    ns4.weycrest.net 83.167.189.134
    ns5.weycrest.net 83.167.189.135

    Is that correct if I am trying to set up private nameservers ns1 and ns2.xeaura-host.co.uk

    I am probably doing the private nameservers thing wrong anyway but I cant understand why I cannot send email from my server to external domains.

    Any ideas?

    Thanks

    Daniel
     
  2. pacificw

    pacificw Well-Known Member

    Joined:
    Aug 26, 2007
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    change your resolv.conf to this and should work


    then just make sure you have a dns zone record
    for each. restart named and all should work. remember
    give it at least 30mins to start resolving.

    HTH
     
  3. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I need zone records for weycrest.net?
     
  4. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I changed resolv as you described. My subdomains are working correctly now.

    I am also recieving emails, but I am still getting the following Mail deliery error:

    skinner@destiny-denied.co.uk
    SMTP error from remote mail server after MAIL FROM:<nobody@server.xeaura-host.co.uk> SIZE=2450:
    host mailserver.destiny-denied.co.uk [213.171.216.66]:
    550 <nobody@server.xeaura-host.co.uk>: Sender address rejected:
    Domain not found


    This is even though I just recieved the email at the very same address (skinner@..)

    I will give it 30 mins like you said and see if I am still getting the error.

    Thanks for the help and quick response!
     
  5. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Problem Solved

    Thank you very much, all is working ok now!
     
  6. skina

    skina Member

    Joined:
    Sep 21, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Sorry to bring this up again, I dont think the problem is completely solved!

    Basically, I was getting issues with emails being set to external domains via PHP mail(). This appears to be resolved now. However, any email that CPanel sends me (skinner[at]destiny-denied.co.uk - the main contacts for CPanel) doesnt get sent with the following error:

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    skinner@destiny-denied.co.uk
    SMTP error from remote mail server after MAIL FROM:<root@server.xeaura-host.co.uk> SIZE=1926:
    host mailserver.destiny-denied.co.uk [213.171.216.66]:
    550 <root@server.xeaura-host.co.uk>: Sender address rejected:
    Domain not found



    The wierd thing is, I have set all root mail to be forwarded to skinner[at]destiny-denied.co.uk and it manages to send the errors to my email address.

    E.G, I recieved this email when checking my skinner[at]destiny-denied.co.uk email address (which is hosted on another server):

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    skinner[at]destiny-denied.co.uk
    SMTP error from remote mail server after MAIL FROM:<root@server.xeaura-host.co.uk> SIZE=1926:
    host mailserver.destiny-denied.co.uk [213.171.216.66]:
    550 <root@server.xeaura-host.co.uk>: Sender address rejected:
    Domain not found

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <root@server.xeaura-host.co.uk>
    Received: from root by server.xeaura-host.co.uk with local (Exim 4.68)
    (envelope-from <root@server.xeaura-host.co.uk>)
    id 1IZAyH-0000ri-1W
    for skinner[at]destiny-denied.co.uk; Sat, 22 Sep 2007 19:48:57 +0000
    To: skinner[at]destiny-denied.co.uk
    From: cpanel@server.xeaura-host.co.uk
    Subject: New account on server.xeaura-host.co.uk (jskinner.co.uk)
    Message-Id: <E1IZAyH-0000ri-1W@server.xeaura-host.co.uk>
    Date: Sat, 22 Sep 2007 19:48:57 +0000

    +===================================+
    | New Account Info |
    +===================================+
    | Domain: jskinner.co.uk
    | Ip: 83.167.189.145 (n)
    | HasCgi: n
    | UserName: jsc
    | PassWord: *
    | CpanelMod: x3
    | HomeRoot: /home
    | Quota: 0 Meg
    | NameServer: ns1.xeaura-host.co.uk
    | Contact Email: skinner[at]destiny-denied.co.uk
    | Package: undefined
    +===================================+
    Account was setup by: root (root)


    Is this wierd? My server cannot send an email to skinner[at]destiny-denied.co.uk but manages to send an email to skinner[at]destiny-denied.co.uk telling me that it couldnt send the email?

    I am a newb, I must be missing something really obvious here!
     
Loading...

Share This Page