The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Mail Delivery Failed" messages in my inbox

Discussion in 'E-mail Discussions' started by Devilfish, Dec 22, 2016.

  1. Devilfish

    Devilfish Member

    Joined:
    Dec 7, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    51
    Hi everyone,

    I have a large vBulletin forum on my server and my admin email inbox receives many "Mail delivery failed: returning message to sender" emails on a daily basis. The main reason for this is when people register on the forum they have entered an incorrect email address. The forum requires that the email address is verified before they can post so this email gets bounced back to me and appears in my inbox.

    I regularly purge the 'email requiring confirmation' usergroup but I would like to stop receiving these messages in my email account so that I can concentrate on the important emails coming from the server.

    Does anyone know how I can stop these emails?

    PHP Handler - CGI
    Apache suEXEC - on

    Many thanks
    Glen
     
  2. Eminds

    Eminds Well-Known Member

    Joined:
    Nov 10, 2016
    Messages:
    174
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Well I believe the issue you are facing is not related to cpanel , its with the vbulletin settings that needs to be tweaked. You will have to check with this issue with some other technical forums.
     
  3. Devilfish

    Devilfish Member

    Joined:
    Dec 7, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    51
    I don't believe the issue is with vBulletin. vBulletin is acting as it should.

    Here is an example of the returned message...

    Code:
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
      someusr@yahoo.com[
       host mta6.am0.yahoodns.net [98.136.217.202]
       SMTP error from remote mail server after end of data:
       554 delivery error: dd This user doesn't have a yahoo.com account
    (someusr@yahoo.com) [-5] - mta1346.mail.gq1.yahoo.com
    
    I was hoping there was a WHM or cPanel setting that would catch these types of emails before delivering it to my inbox and ignore it perhaps.

    Could I add something to the SPAM filter to stop messages with specific words in the subject from being delivered to me?
     
    #3 Devilfish, Dec 22, 2016
    Last edited by a moderator: Dec 22, 2016
  4. linux4me2

    linux4me2 Well-Known Member

    Joined:
    Aug 21, 2015
    Messages:
    149
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    What if you go into cPanel and then in the Email section, click Email Filters, click Manage Filters for the email account the emails are going to, and create an email filter based on the subject of the emails to discard the messages. It seems like that will accomplish what you want.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The bounced message is coming from Yahoo, and is sent when your server attempts to send an email to a Yahoo email address that doesn't exist. You can't prevent Yahoo from bouncing the message, so you'd have to setup an email filter that discards messages matching the content of the specific Yahoo bounce. If it's bounced to the root server contact (e.g. root@yourservershostname), you'd have to setup a custom system filter rule:

    How to Customize the Exim System Filter File - cPanel Knowledge Base - cPanel Documentation

    Thank you.
     
Loading...

Share This Page