The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail delivery failed: returning message to sender

Discussion in 'E-mail Discussions' started by Hostbox.be, May 29, 2003.

  1. Hostbox.be

    Hostbox.be Well-Known Member

    Joined:
    Nov 4, 2002
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    When my clients send an email and for some reason this mail bounces back, then I get this error and not my client ?

    I get every day many mails with subject "Mail delivery failed: returning message to sender", but instead of returning to sender, they come to me (nobody@myservername)!

    Is it possible to change this, so my clients got their own error-email back ?

    Please all help is appreciated !!

    Kind regards,

    www.priorhost.be
    (I run last version of Exim)

    cPanel.net Support Ticket Number:
     
  2. Hostbox.be

    Hostbox.be Well-Known Member

    Joined:
    Nov 4, 2002
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    I forgot something to say....

    suExec is currently enabled on my server ! But this doesn't help ?

    cPanel.net Support Ticket Number:
     
  3. clement01

    clement01 Member

    Joined:
    Aug 12, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I am faced with the same problem.

    Clients who's mail box is full complained that their customers did not get their earlier mail bounced back to them.

    instead all the mails got bounced to me@mydomain.com

    please advise anyone...
     
  4. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    Re: I forgot something to say....

    is it possible these emails are coming from PHP scripts, as it's coming from "nobody"... if your not using PHPsuexec, PHP compiled as CGI... and in your WHM>>Tweak setting, you can prevent any emails being sent from "nobody", in the WHM>>Change System Mail Preferences, there is a setting to have "nobody" emails sent to a specific address too, do you have an email address assigned for that ??

    Mickalo
     
  5. clement01

    clement01 Member

    Joined:
    Aug 12, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi Mikalo

    Thanks for your input, I have tried what you suggested but it does not solve the problem.

    In the exim logs the extracted portion is as follow:

    ###################################
    <= webmaster@mydomain.com U=webmaster P=local-bsmtp S=976951 id=200406241046.AA319
    553852@bananas01.2bananas.com
    2004-06-25 00:53:46 1BdXTu-0002Li-CN == testuser@mydomain.com R=virtual_user T=virtual_userdelivery defer (-22): mailbox is
    full (MTA-imposed quota exceeded while writing to /usr/home/webmaster/mail/mydomain.com/testuser/inbox)
    2004-06-25 00:53:46 1BdXTu-0002Li-CN ** testuser@mydomain.com: retry timeout exceeded
    2004-06-25 00:53:47 1BdXTu-0002Lp-UI <= <> R=1BdXTu-0002Li-CN U=mailnull P=local S=108485
    2004-06-25 00:53:47 1BdXTu-0002Li-CN Completed
    2004-06-25 00:53:47 1BdXT4-0002KJ-Vo => testuser <testuser@mydomain.com> R=virtual_sa_user T=virtual_sa_userdelivery
    2004-06-25 00:53:47 1BdXT4-0002KJ-Vo Completed
    2004-06-25 00:53:49 1BdXTv-0002Lt-2L <= webmaster@mydomain.com U=webmaster P=local-bsmtp S=108897 id=E1BdXTu-0002Lp-UI@
    mydomain.com
    2004-06-25 00:53:49 1BdXTv-0002Lt-2L => webmaster <webmaster@mydomain.com> R=localuser T=local_delivery
    2004-06-25 00:53:49 1BdXTv-0002Lt-2L Completed
    2004-06-25 00:53:49 1BdXTu-0002Lp-UI => webmaster <webmaster@mydomain.com> R=sa_localuser T=local_sa_delivery
    2004-06-25 00:53:49 1BdXTu-0002Lp-UI Completed
    ####################################3


    So you can see that when exim realize the mail box of testuser is full, it sends a bounce message not to the original sender but to the account webmaster@mydomain.com.

    Apparently, it is this account webmaster that is doing the middleman job of relaying the mails(when the mails come to the server, it is identified by domain and its respective owner, when its valid, the mail will be handed over to the owner of the domain to be delivered to its users). But in the case of bounce mail, instead of relaying the bounce mail, it stores it in its inbox.

    how can this be the default behaviour?
     
  6. clement01

    clement01 Member

    Joined:
    Aug 12, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    Just dropping a note to say I managed to find the cause of the problem.

    Simply disable spamassasin in the domains's home dir and the problem will be resolved.
     
Loading...

Share This Page