The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail delivery failed: returning message to sender

Discussion in 'E-mail Discussions' started by SHSaeed, Jul 20, 2002.

  1. SHSaeed

    SHSaeed Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    Hi guys,

    Is there anyway to have these emails to be actually returned to the sender (the email listed in From:) instead of having them all come to the email set in WHM?
     
  2. SHSaeed

    SHSaeed Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    *bump*

    A month has gone by and no answer.. Anyone know if/how this can be done?
     
  3. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Mar del Plata - Argentina
    UP !

    Same problem here, every time that an email sended from one of our clients scripts bounce for any reason, i got an "Mail delivery failed: returning message to sender" mail.

    I want all those emails go to the sender and not to ROOT !
     
  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,572
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    use phpsuexec
     
  5. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Mar del Plata - Argentina
    I heard that phpsuexec may be incompatible with some programs. Do you know what kind of incompatibility is ?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,176
    Likes Received:
    167
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  7. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,572
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider

    it is mail scripts sending as nobody but I have found if phpsuexec is compiled before adding any sites they work just fine I run several noboody scripts and they all run just fine


    there might be other things that it mucks up but I nor any of my customers have encountered any or they just do not let me know?
     
  8. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    532
    Likes Received:
    0
    Trophy Points:
    16
    search the forums here for some exim config settings to restore the old functionality that was changed recently. I believe chirpy posted them.

    otherwise fix your scripts so that they set the return-path properly when they call the mail sending binary. (it's the 5th variable)
     
Loading...

Share This Page