The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail delivery failed: returning message to sender

Discussion in 'E-mail Discussions' started by ramon1978, Oct 26, 2007.

  1. ramon1978

    ramon1978 Registered

    Joined:
    Apr 21, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I recently made my RDNS on my server and now I cannot send any e-mails.
    on the mainlog of exim I have received this kind of error
    2007-10-26 21:36:36 1IlU2u-0002uQ-RX User 0 set for local_delivery transport is on the never_users list
    2007-10-26 21:36:36 1IlU2u-0002uQ-RX == root@host.global-internet.ro <nobody@host.global-internet.ro> R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    2007-10-26 21:37:32 Start queue run: pid=11237
    2007-10-26 21:37:32 1IlTUZ-0002cc-R9 == root@host.global-internet.ro <nobody@host.global-internet.ro> R=localuser T=local_delivery defer (-52): Retry time not yet reached
    2007-10-26 21:37:32 1IlTUZ-0002ce-UL == root@host.global-internet.ro <nobody@host.global-internet.ro> R=localuser T=local_delivery defer (-52): Retry time not yet reached
    2007-10-26 21:37:32 1IlTHA-0002Wg-IB == root@host.global-internet.ro <nobody@host.global-internet.ro> R=localuser T=local_delivery defer (-52): Retry time not yet reached
    2007-10-26 21:37:32 1IlU2u-0002uQ-RX == root@host.global-internet.ro <nobody@host.global-internet.ro> R=localuser T=local_delivery defer (-52): Retry time not yet reached
    2007-10-26 21:37:32 End queue run: pid=11237
    [root@host named]# 2007-10-26 21:37:32 1IlU2u-0002uQ-RX == root@host.global-internet.ro <nobody@host.global-internet.ro> R=localuser T=local_delivery defer (-52): Retry time not yet reached
    -bash: syntax error near unexpected token `('
    [root@host named]# 2007-10-26 21:37:32 End queue run: pid=11237

    Can someone tell me wich is the problem here?
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    This is well documented in the forums. A search for "never_users list" will give you some assist.

    The answer:

    1. Log into WHM
    2. Click on Tweak Settings
    3. Find:

    Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)

    Uncheckmark that option and save.

    I'm guessing you aren't running suPHP. If not, you really should search the forums and read about the benefits of doing so. There are many.

    If you were running suPHP, your scripts would be sending email as some_account_name@host.global-internet.ro. But since you aren't running suPHP, the scripts send out mail as nobody@host.global-internet.ro. So you have to uncheck the option in Tweak Settings.

    Mike


     
Loading...

Share This Page