The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail.domain.com Defaulting to IPv6. Why? [Case 80257]

Discussion in 'E-mail Discussions' started by wswd, Oct 28, 2013.

  1. wswd

    wswd Well-Known Member

    Joined:
    Aug 9, 2005
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hello,

    When IPv6 is enabled on an account, mail.domain.com (for checking POP3 and the like) defaults to IPv6. You can test it by pinging mail.domain.com.

    I don't want that to happen. I have already disabled IPv6 in EXIM, but that doesn't seem to work. It broke email on my phone, as IPv6 wasn't working appropriately on my phone. I imagine other clients on our servers were experiencing the same, so I had to disable IPv6 temporarily.

    Anyone?
     
    #1 wswd, Oct 28, 2013
    Last edited: Oct 28, 2013
  2. wswd

    wswd Well-Known Member

    Joined:
    Aug 9, 2005
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    After some further research, it looks like the domain itself also defaults to IPv6. Pinging the domain uses IPv6 instead of IPv4.

    - - - Updated - - -

    Disregard. This is apparently what Windows does by default. Had to fix that. ;)

    On a side note...anyone know how to force an Android phone to use IPv4?
     
    #2 wswd, Oct 28, 2013
    Last edited: Oct 28, 2013
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Exim prefers IPv6 over IPv4 by default. There is an internal case open to address this issue and ensure IPv4 is preferred. For reference, the case number is 80257. This change is scheduled for cPanel version 11.40.0.13. You can monitor our change log to see when it's implemented:

    cPanel - Change Log

    Thank you.
     
  4. wswd

    wswd Well-Known Member

    Joined:
    Aug 9, 2005
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Thanks Michael! Sounds good.
     
  5. radeonpower

    radeonpower Well-Known Member

    Joined:
    Jul 23, 2009
    Messages:
    129
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Yeah, regarding the Changelog, it seems not being updated regularly. I see the latest changes in 11.40.0.9. This seems to happen quite often.

    Also regarding the IPv6 in Exim, I would also like to see the option on be able to specify one IPv6 IP Exim uses to send out instead of it using the last added IP(v6) to the system.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I recommend opening a feature request for this via:

    Submit A Feature Request

    It's important to keep in mind that we only support IPv6 for website content at this time. IPv6 support for sending and receiving email will come in a future release.

    Thank you.
     
  7. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Michael, according to the changelog, setting IPv6 to Disabled was fixed in 11.40.0.16, but I have 11.40.0.26 and it's not fixed. Can you clarify the situation?

    - Scott
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Here is a snippet of the case description:

    This case was pushed out with cPanel version 11.40.0.16. Does Exim still favor IPv6 on your system? If so, please open a support ticket to let us know. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  9. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Hi Michael. Yes, every server that auto-updated to 11.40.0.26 is favoring IPv6. Unfortunately, you can't see it broken, because I had to fix it, so we could deliver mail to GMail (and any other host checking for proper rDNS for IPv6, which our data center doesn't yet support). I had to follow the directions that you specified here:

    http://forums.cpanel.net/f5/mail-pu...ss-failing-spam-check-349742.html#post1403282

    I still have several boxes that haven't auto-updated. I will open a ticket when those are upgraded and it breaks those...and it will :)

    - Scott
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You are welcome to report this issue and request that we utilize a test server to reproduce it. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  11. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Ticket #4414241
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, it looks like this was happening on cPanel 11.38. The issue is confirmed as fixed in cPanel version 11.40. You can verify the correct Exim RPM is installed with this command:
    Code:
    # rpm -qa --changelog exim | grep "Prefer IPv4"
    - Prefer IPv4 MX over IPv6 when both are available.
    Thank you.
     
  13. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Hi Michael. You are right... I'm red-faced. I first saw the problem the exact same day that some of my boxes were auto-updated to 11.40. I put 1+1 together and, well, I was wrong. It is, indeed, the 11.38 boxes that were preferring IPv6, not the 11.40 boxes.

    Sorry for the confusion!

    - Scott
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page