The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail.domain.com/mailman/ - how to change domain

Discussion in 'E-mail Discussions' started by Svintoo, Nov 11, 2009.

  1. Svintoo

    Svintoo Member

    Joined:
    Apr 16, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I've searched the forums with no luck of finding an answer to this one, so here goes.

    As most already know, the mailman lists doesn't follow when changing the main domain of an account. I fixed this manually without a problem, but one thing remains: mail.newdomain.com/mailman/ doesn't work.

    Since I re-added the olddomain as a parked domain it can still be reached with mail.olddomain.com/mailman/

    What I'm wondering is where I can find the configuration for this.
    QUESTION: What configuration file tells the server to deliver the mailman page for specific mail.-subdomains?

    I haven't found anything in WHM and I have no idea where to look in the file system to change this.
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    WHM Tweak Settings option to use the "mail." (sub-domain) prefix for mailman URLs

    The option to use the "mail." (sub-domain) prefix for mailman URLs is configurable via the Tweak Settings page in WHM as found at the following menu path:
    WHM: Main >> Server Configuration >> Tweak Settings >> Mail

    At the above menu path, the option appears as follows:
    Code:
    Add the mail. prefix for mailman URLs (i.e. http://mail.domain.com/mailman)
    Documentation: Tweak Settings
     
  3. Svintoo

    Svintoo Member

    Joined:
    Apr 16, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thanks cPanelDon, but that didn't really answer my question.
    The problem wasn't how to activate the mail. prefix for Mailman.

    The problem was that even though I changed the main domain for an account (from olddomain.com to newdomain.com) and manually transferred all mailman lists, Mailman still showed the lists under the old domain (mail.olddomain.com/mailman/) but not under the new domain (mail.newdomain.com/mailman/).

    But I managed to solve the problem.
    SOLUTION: By deactivating and then reactivating the "Add the mail. prefix for mailman urls" under Tweak settings the url was updated on the server.

    But your tip pointed me in the right direction. Thanks again ;)
     
Loading...

Share This Page