The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail From My Domain Delivered to Junk

Discussion in 'E-mail Discussions' started by empowerweb, Jun 27, 2014.

  1. empowerweb

    empowerweb Registered

    Joined:
    Jun 27, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    All 3 major email providers (gmail, yahoo, hotmail) deliver my emails to the junk folder. I have SPF, DKIM and rDNS all setup and the SPF and DKIM have a "pass" in every email header delivered to junk. I haven't been sending any spam email's which would cause these 3 to put my domain on the spam list and the only current abnormality i see in the headers of my emails is a IP used for the HELO name instead of a domain name.

    This is an example of a email header from 2013 which was sent from my domain and which seemed to be delivered fine:

    Received: from localhost.localdomain ([127.0.0.1]:51080 helo=webmail.xxxx.com.au)
    by server1.xxxx.com.au with esmtpa (Exim 4.82)
    (envelope-from <web@xxxx.com.au>)
    id 1VpFFq-0007x4-0T
    for xxxx@hotmail.com; Sat, 07 Dec 2013 21:06:58 +1030

    while this is how the current snippet of the mail header looks like:

    Received: from localhost ([::1]:54382 helo=103.x.x.x)
    by server1.xxxx.com.au with esmtpa (Exim 4.82)
    (envelope-from <web@xxxx.com.au>)
    id 1X0Swg-0004oQ-QY
    for xxxx@hotmail.com; Fri, 27 Jun 2014 19:29:51 +0930

    I've made no changes to the configuration and im wondering how would i revert it to the old header and is that a thing that could make those 3 mail services place my emails in the junk folder?

    Thanks
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
  3. empowerweb

    empowerweb Registered

    Joined:
    Jun 27, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    It all returns as "OK", the only spam triggering thing left in my email headers seems to be the IP address used for HELO. I don't know what could be misconfigured so that the IP is used instead of a domain name.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page