The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail from php forms delayed, delivered once per hour?

Discussion in 'E-mail Discussions' started by jamesbond, Apr 8, 2003.

  1. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I noticed the strangest thing...

    E-mail from php forms is being delivered once per hour , every 14th minute of the hour...

    Regular mail is still instantly delivered.

    I'm on 6.4.0-S3 (RH 7.3)

    UPDATE:
    I see the messages in the WHM queue


    I also found the following:

    root@host [/var/spool/exim/msglog]# cat 1930o2-0004sG-00
    2003-04-08 21:39:02 ****@********.coml T=remote_smtp defer (-44): retry time not reached for any host

    Anyone?

    P.S. The delay only occurs when e-mail is sent to domains not located on the server.
     
    #1 jamesbond, Apr 8, 2003
    Last edited: Apr 8, 2003
  2. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    When I click on deliver e-mail in WHM, the mails are being delivered...so why do they get stuck in there? :(

    Just for the record, I don't have 'Prevent the user 'nobody' from sending out ...' enabled.


    Ok I just tried sending from a form to 5 differerent e-mail addresses (located on different servers in different parts of the world) :

    And in /var/log/exim_mainlog I see the following error for all 5 :

    Malformed SMTP response from xxxxxxx.com [xxx.xxx.xxx.xx] after initial connection: 220 xxxxxxxx.com ESMTP Sendm


    As I said this only happens to mail sent from php forms to external e-mail addresses....
     
    #2 jamesbond, Apr 8, 2003
    Last edited: Apr 8, 2003
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Well it seems to suddenly work again! :)

    I can go to sleep now! :D
     
  4. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Ok this is insane...I'm having the same problem again... :(

    e-mail sent from php forms to external e-mail addresses end up sitting in the mail queue....

    Once I click 'Deliver' in WHM they are promptly delivered.

    Did anyone else notice this or am i the only one with this problem?
     
  5. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    I have been having a high load average problem with exim, which may be related. 2 nights ago, after a nightly update, I woke up an had 2 servers that I could not access. I rebooted them and logged in via SSh to find that the load average was 12.00 and above.

    I finally found that exim was spinning zombie processes 15-20 at a time. This evidently was causing a problem.

    I think that exim was updated at that time (I can't be sure) and there is something wrong with the new exim or something was updated that exim now has a problem with....

    View these threads about the same issue...

    http://forums.cpanel.net/showthread.php?s=&threadid=8656

    http://forums.cpanel.net/showthread.php?s=&threadid=8531
     
  6. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Possibly, although I only have 1 exim process running and I don't have high loads.

    root@host [/var/log]# ps -ax | grep exim
    20253 ? S 0:00 /usr/sbin/exim -bd -q1h

    What I would like to know what has changed since the updates...it's kind of hard to know what is going wrong if no one will tell you what has changed.


    messages send from php forms all cause this error in /var/log/exim_mainlog now :

    T=remote_smtp defer (0): SMTP error from remote mailer after RCPT TO

    :(
     
    #6 jamesbond, Apr 9, 2003
    Last edited: Apr 9, 2003
  7. timo

    timo Registered

    Joined:
    Apr 10, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    email once an hour

    I have the same problem. Somehow PHP sends the mail only to the exim queue or exim somehow does not know to deliver it immediately. As mentioned above the problem sometimes disappears but comes back after few hours.

    I have exim 3.36-121 and I suspect this problem started after one of the exim upgrades.

    I have PHP 4.2.3. Would an upgrade to PHP 4.3.1. help ?

    I have temporarily fixed this so that the whole queue is being deliver once a minute instead of an hour (changed QUEUE parameter in exim start-up config file in /etc/init.d/exim).
     
  8. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    I knew I couldn't be the only one with this problem :)

    So in /etc/init.d/exim I change :

    QUEUE=1h

    to

    QUEUE=1m

    right?

    P.S. I'm running php 4.3.1 with exim-3.36-121
     
  9. timo

    timo Registered

    Joined:
    Apr 10, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Only problem is that if someone enters bad email address it tries to send it on every minute for 24 hours and that kills CPU. So I recommend to limit the retries for maybe to only 2 h.
     
  10. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Any of youe in here still having the issue?
     
  11. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
    Well i hope this fixes that problem
     
  12. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    didnt here, still the same delays, customers getting really annoyed at this :|
     
  13. Slav

    Slav Well-Known Member

    Joined:
    Oct 28, 2002
    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    16
  14. fgauthier

    fgauthier Member
    PartnerNOC

    Joined:
    Feb 22, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1

    I have set it to 30 minutes and the delay is just fine. Worths a try!
     
  15. ezwebscripts

    ezwebscripts Member

    Joined:
    Sep 28, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Yep, I'm having this problem too. I just got a new server with CPanel, and this seems to be the only problem I've noticed so far. It appears to only have this problem with "some" e-mail addresses, and sometimes instead of delaying, it doesn't send at all, and just sits in mail queue for days. If anyone has a clue on how to fix this - HELP!
     
  16. smerkel

    smerkel Member

    Joined:
    Feb 19, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Greetings:

    I thought I would join the band-wagon. Here is what I've been seeing:

    PHP mail() will work fine, then quit working. If Apache is restarted, it's fine again until the next morning. We are starting to see this on multiple servers. I watch the mail enter the exim queue, but it will be delivered (maybe) hours later.

    As a likely related side note: One server is having a similar issue with the ftp related routines. The script is not able to connect via FTP until Apache is restarted. After the restart everything is fine. I busted out some tcpdump and captured the FTP session: The connection occurs, the header is returned from destination server, and poof... nothing. Again, restart apache, and all is fine with the world.

    There is definitely a problem with either Apache or the PHP module. We have tried different things (removing safemode, upgrading to 4.3.2) but we have had no luck so far. This has been going on for a month or so now and is really driving me nuts (especially given that it is being reported on other servers now.)

    It would be appreciated if the Cpanel development team would join the fight and help resolve the issue.

    Best regards,

    Steve

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  17. fgauthier

    fgauthier Member
    PartnerNOC

    Joined:
    Feb 22, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    apache

    Hi,

    we experienced this problem aswell, you need to use the latest buildapache available at layer1.cpanel.net and it is gonna fix it.

    regards,

    cPanel.net Support Ticket Number:
     
  18. Keegan

    Keegan Well-Known Member

    Joined:
    Oct 22, 2001
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Its related to apache in some way. Like there is something that will not let apache send mail if it is already using something else, but I have no idea really.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page