Mail IP Changed messing up EXIM SMART HOST

imageinabox

Member
Nov 20, 2013
21
2
3
Huntsville, AL
cPanel Access Level
Root Administrator
Twitter
cPanel recently updated mailip structure to include IPv6 Addresses. Not sure if this was related to 54 or not.

Old way:
Code:
example.com: 192.168.1.1
New way:
Code:
example.com: 192.168.1.1; 2607:f129:90::1
Now my smarthost exim change do not work because of lsearch doesn't know how to handle the ;.

Here is my exim code:

Code:
@[email protected]
remote_smtp_smart_dkim:
  driver = smtp
  hosts_require_tls = *
  interface = ${if exists {/etc/mailips}{${lookup{$sender_address_domain}lsearch*{/etc/mailips}{$value}{}}}{}}
  helo_data = ${if exists {/etc/mailhelo}{${lookup{$sender_address_domain}lsearch*{/etc/mailhelo}{$value}{$primary_hostname}}}{$primary_hostname}}
  dkim_domain = $sender_address_domain
  dkim_selector = default
  dkim_private_key = "/var/cpanel/domain_keys/private/${dkim_domain}"
  dkim_canon = relaxed

remote_smtp_smart_regular:
  driver = smtp
  hosts_require_tls = *
  interface = ${if exists {/etc/mailips}{${lookup{$sender_address_domain}lsearch*{/etc/mailips}{$value}{}}}{}}
  helo_data = ${if exists {/etc/mailhelo}{${lookup{$sender_address_domain}lsearch*{/etc/mailhelo}{$value}{$primary_hostname}}}{$primary_hostname}}
This is the exim error I get:
Code:
: "192.168.1.1; 2607" is not a valid IP address for the "interface" option for remote_smtp_smart_dkim transport

Does anyone have a way to fix the "interface" lines. Any help is appreciated. :/