The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Issue

Discussion in 'E-mail Discussions' started by TheBee, Nov 28, 2004.

  1. TheBee

    TheBee Member

    Joined:
    Nov 27, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Whenever I send an e-mail whether I am using NeoMail, Horde, SquirrelMail or just Outlook the message's FROM field always shows up <myusername@machine.hostingcompaniesdomain.com> on behalf of <myemailbox@mydomain.com>.

    Whenever I receive a message the FROM field always shows <myusername@machine.hostingcompaniesdomain.com> on behalf of <whomever it was sent by@domain.com>.

    How do I fix this?

    Thanks.

    jlr
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    In WHM > Service Configuration > Exim Configuration Editor, there is the tickable option:

    "Always set the Sender: header when the sender is changed from the actual sender. (Unchecking this will stop "On behalf of" data in Microsoft(R) Outlook, but may limit your ability to track abuse of the mail system.)"

    From what I understand (gained from limited experience and therefore maybe wrong), Outlook will add the "On behalf of" malarky if the Sender: header is present in mail and differs from the From: header. I believe that this will only happen when viewing mail through Outlook.

    In short, unchecking the above mentioned option should stop this, but I'm not sure if that's a good idea (still trying to figure this out myself).

    If anyone's got any bright ideas how to keep the above option ticked and stop Outlook from "On behalf of"-ing messages, please let me know!
     
Loading...

Share This Page