The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail issues - php forms (did a search)

Discussion in 'E-mail Discussions' started by kory, Dec 6, 2005.

  1. kory

    kory Member

    May 20, 2005
    Likes Received:
    Trophy Points:
    Howdy all. I'm hoping y'all can help me.

    I've been racking my brain for the past week, scouring through the forum here for any advice, and making various changes to repair a spam issue that came up last week. Now, none of the PHP-based forms on my sites are working and I'm pretty much out of ideas.

    I've sent a message to the sysadmins where my server is and they're not able to help. I've followed excellent suggestions that chirpy posted and all worked yesterday but when I checked this morning, I discovered that the forms aren't processing messages.

    This is what I sent to my sysadmins:

    Hello. I thought I had my PHP mail issues worked out yesterday as I was successfully receiving messages through various PHP forms on the various sites. All of them run on independent PHP scripts so I don't think it's a scripting issue. The spam issue has been eliminated but now I'm not receiving any messages via the forms.

    Some background info:

    I did quite a bit of research on the forums at and performed the following procedures, based on my research there:

    1. Installed phpsuexec.

    2. Deselected the "Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)" under "tweak settings"

    3. Deselected the "Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required)"

    4. Performed an Exim update via "/scripts/updatenow" and "/scripts/eximup --force"

    5. Confirmed that sh is not executable as "nobody" but instead as "root" - might this be an issue? -rwxr-xr-x 1 root root 586132 Apr 13 2005 bash* and lrwxrwxrwx 1 root root 4 Nov 7 21:40 sh -> bash*

    6. Performed a /scripts/updatenow and a /scripts/updatephpconf

    7. Installed MailScanner per

    8. Installed a Dictionary ACL to combat the spammers per

    9. Here's a recent tail of the exim_mainlog (all these messages were sent via forms):

    2005-12-06 10:23:58 1Ejefe-0005NJ-0g <= U=wispcent P=local S=612

    2005-12-06 10:23:58 1Ejefe-0005NK-1d <= U=wispcent P=local S=728

    2005-12-06 10:25:29 1Ejeh7-0005R0-0z <= U=stuhall P=local S=551

    10. As a last resort, ran /scripts/fixeverything and /scripts/fixrelayd.


    I'm happy to answer any questions anyone might have, as well as providing updated log info.

    I'm truly at a loss here.

    Thx much, in advance.


Share This Page