The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail not deleting from queue

Discussion in 'E-mail Discussions' started by masterminds, Feb 29, 2004.

  1. masterminds

    masterminds Member

    Joined:
    Feb 21, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    We are running cpanel 9.0.0 R25 after we updated the mail in the mail queue stopped being deleted upon delivery.

    We have sent severel test messages to try and figure out what is going on and can not figure it out. We recieve the message but it is not being removed from the queue. Any ideas as to what may be causing this problem. We are having to delete the mail queue by hand to keep the server load down and exim functioning properly.
     
  2. Keegan

    Keegan Well-Known Member

    Joined:
    Oct 22, 2001
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    In the /etc/exim.conf file, around line 200, there is a section that says:

    # This option cancels (removes) frozen messages that are older than a week.
    timeout_frozen_after = 7d

    Change it to what you want, then restart exim from shell for the changes to take effect.
    /etc/rc.d/init.d/exim restart

    You can also modify it with "Exim Configuration Editor" in WHM.
     
  3. masterminds

    masterminds Member

    Joined:
    Feb 21, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    It's not the messages that are not grtting delivered that is a problem. Any message that hits the queue stays there whether it gets delivered or not and our timeout_frozen_after = 7d reads:timeout_frozen_after = 1h. It is just not deleting the file in the /var/exim/input once it is delivered.
     
  4. masterminds

    masterminds Member

    Joined:
    Feb 21, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Can someonr Please HELP!!

    Can soeone please help us with this problem it is causing all kinds of problems and we have ran every script in the scripts directory.
     
  5. maverick

    maverick Well-Known Member

    Joined:
    Jan 6, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    I'm experiencing a similar problem. Mail is being delivered okay, but they are not being removed from the queue. On closer inspection, it actually appears that only the header is being kept in the queue and no size is given in the mail queue listing in WHM.

    The other interesting thing is that the items in /var/spool/exim/input which are not being deleted have permissions set to 600 rather than 640 like they are on our other servers.

    Any suggestions?

    I've tried /scripts/exim4 and /scripts/upcp - but all to no avail.

    Mav.
     
    #5 maverick, Mar 24, 2004
    Last edited: Mar 24, 2004
Loading...

Share This Page