The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail not sending, receiving slowly

Discussion in 'E-mail Discussions' started by bmcclure, Feb 28, 2004.

  1. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    I've got a virtual dedicated server with Rackforce so I am opening a ticket with them, just seeing if you guys have seen thsi before. I URGENTLY need this fixed as I'm starting to get a swarm of new customers.

    Whenever I try to send mail, whether through SMTP or from my website via sendmail, it gets returned with the following:

    Connection refused:
    retry timeout exceeded


    No matter where I send it...

    Also, when receiving email, I ge a few random emails all the time, but then every few hours I get a ton of email covering the last few hours.

    Any help? Thanks!
     
  2. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    Checked the queue for these messages that get refused, and they get refused almost instantly by the remote server it appears. What could be wrogn with my server? I know it's not blocked because it's a new IP and new server.
     
  3. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    nevermind

    Hmph...

    post on WebHostingTalk

    lifeisboost
    not sure if you problem is the same as mine but this came up when i moved to a new dedicated server. all outbound mail was connection refused and built up in the queue I had a weird firewall entry in my IPtables



    this is what i did to find it. maybe this is the same problem



    SSH into your server under root and run this



    iptables -L | more



    i found this line under chain OUTPUT



    target prot opt source destination ACCEPT tcp -- anywhere localhost tcp dpt:smtp REJECT tcp -- anywhere anywhere tcp dpt:smtp reject-



    to get rid of it i ran these commands



    iptables -D OUTPUT 2

    iptables -D OUTPUT 1



    emailed flowed correctly after that.





    what i found out is the SMTP tweak was enabled and was adding that line on startup.
     
  4. bmcclure

    bmcclure Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Racine, WI
    Works flawlessly now... nice.
     
Loading...

Share This Page