The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail not working

Discussion in 'E-mail Discussions' started by bou3lam, Oct 1, 2009.

  1. bou3lam

    bou3lam Active Member

    Joined:
    Sep 29, 2009
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    we purchased a dedicated lately , i have created an reseller account under which i have hosted some sites mine , the mail isnt working , when i send email to this account nothing arrive , the support told me this :
    Hello,

    I am noticing a lot of emails from nobody@newint.domain.com; This is going to fail due to the host name not being valid.

    I altered the hostname to 'test' and was able to send myself to myself via command line and your other users.


    what to do please
     
  2. bou3lam

    bou3lam Active Member

    Joined:
    Sep 29, 2009
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    strange , the emails arrived , but they took some time ! some 2 hours ! but its not arrived to all accounts
     
    #2 bou3lam, Oct 1, 2009
    Last edited: Oct 1, 2009
  3. bou3lam

    bou3lam Active Member

    Joined:
    Sep 29, 2009
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    i made a dns lokup :


    hostedwebsite.COM NAME SERVERS
    Name Server IP Location
    ns1.myresellerdomain.com
    ns2.myresellerdomain.com
    ping hostedwebsite.com


    hostedwebsite.COM DNS RECORDS
    Record Type TTL Priority Content
    hostedwebsite.com NS 1 day 23 hours 6 seconds ns1.myresellerdomain.com
    hostedwebsite.com NS 1 day 23 hours 6 seconds ns2.myresellerdomain.com
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The hostname for your server needs to be a a FQDN in a cPanel/WHM environment. This means it should be of the format: something.yourdomain.ext

    You can change the server's hostname by using the Hostname screen in the Networking Setup section of WHM.

    Regarding mail, make sure that those domains are using your nameservers, not resellers hosted on another server. That should help with DNS resolving properly.
     
  5. bou3lam

    bou3lam Active Member

    Joined:
    Sep 29, 2009
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    my reseller account main domain is hosted at the main server and using the nameservers of the main webserver domain , my hosted domains under my reseller account are using my reseller account nameservers :(
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    To clarify, are the reseller account nameservers on the same cPanel/WHM server that should be handling the mail etc?
     
  7. bou3lam

    bou3lam Active Member

    Joined:
    Sep 29, 2009
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    yes , the whole accounts ar in the same place
     
  8. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Let's first focus on nobody@newint.domain.com.

    nobody@ is where emails are sent from when they are sent from scripts running as user nobody. You may want to have your customers specify the from and reply-to address in their scripts so responses are sent to the appropriate addresses.

    You can also enable SuPHP via EasyApache to have scripts run as the actual cPanel user and avoid the hassle that comes with having all scripts running as user nobody.

    You can configure your server to accept mail for nobody@hostname by going to the Server Contacts section of WHM and clicking on Change System Mail Preferences. Here you can direct nobody's mail to a specific email address, usually an address of a system administrator.


    As for other accounts not receiving email, try checking /var/log/exim_mainlog to see if there are any delivery issues being reported by Exim (the SMTP server).
     
Loading...

Share This Page