The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail problems after upgrade to cPanel 11

Discussion in 'E-mail Discussions' started by rpertiet, Aug 29, 2007.

  1. rpertiet

    rpertiet Member

    Joined:
    Apr 21, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    WHM 11.2.0 cPanel 11.11.0-C16668
    CENTOS Enterprise 4.5 i686 – WHM X v3.1.0

    After upgrading last night I cannot send or receive mail. From the exim_mainlog I have the following errors:

    Sending out:
    Unable to authenticate at present: Undefined subroutine &main::checkuserpass called.

    Receiving from outside mail:
    sender verify defer : lookuphost router failed to expand "${perl{mailtrapheaders}}": Undefined subroutine &main::mailtrapheaders called.

    I’ve tried rebuilding exim and it showed that it completed normally but still have the problem.

    Any ideas?

    Thanks!
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  3. rpertiet

    rpertiet Member

    Joined:
    Apr 21, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Yes, 5.8.8.
     
  4. rpertiet

    rpertiet Member

    Joined:
    Apr 21, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I have no file /etc/exim.pl, but I do have /etc/exim.pl.local Could this be the issue???
     
  5. rpertiet

    rpertiet Member

    Joined:
    Apr 21, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Problem solved - LES was installed. Once temporally disabled, the upgrade went smooth and email works fine.
     
  6. Bravo

    Bravo Well-Known Member

    Joined:
    Oct 30, 2001
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    was having the same problem, this fixed it

    Code:
    /usr/local/sbin/les --disable-all on
    /scripts/eximup --force
    /usr/local/sbin/les --enable-all on
     
  7. Voltio

    Voltio Active Member

    Joined:
    Oct 17, 2004
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Do you know if this would overwrite any exim configuration or any anti spam systema previously installed?
     
Loading...

Share This Page