The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Problems - Temporary local problem

Discussion in 'E-mail Discussions' started by problemsolver, Mar 1, 2007.

  1. problemsolver

    problemsolver Member

    Joined:
    Mar 1, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I am experiencing mail problems that I can not figure out. I have tried:

    cd /scripts
    ./fixetchosts
    ./checkexim.pl
    ./restartsrv_exim
    ./updateuserdomains
    ./exim4 -force
    ./mailperm
    ./upcp

    and I am still experiencing the same problems.

    I can telnet to the host's pop and login but entourage/outlook are still producing errors.

    Here are some excerpts from some logs:

    /var/log/exim_mainlog

    2007-03-01 13:13:07 1HKlye-00073W-DE Message is frozen
    2007-03-01 13:13:07 1HMLdC-0002Pj-Mh Message is frozen
    2007-03-01 13:13:07 1HL96L-0001Gd-Pv Message is frozen
    2007-03-01 13:13:07 1HKmco-00077r-VD Message is frozen
    2007-03-01 13:13:07 1HMjz6-00066w-Vi Message is frozen
    2007-03-01 13:13:07 End queue run: pid=5468
    2007-03-01 13:21:06 lowest numbered MX record points to local host: *.com (while verifying <*@*.com> from host ([192.168.1.120]) [75.64.x.x])
    2007-03-01 13:21:06 H=([192.168.1.120]) [75.64.x.x] sender verify defer for <*@*.com>: lowest numbered MX record points to local host
    2007-03-01 13:21:06 H=([192.168.1.120]) [75.64.x.x] F=<*@*.com> temporarily rejected RCPT <**@*.com.vn>: Could not complete sender verify
    2007-03-01 13:21:07 unexpected disconnection while reading SMTP command from ([192.168.1.120]) [75.64.x.x]

    /var/log/exim_rejectlog

    2007-03-01 13:01:04 H=([192.168.1.120]) [75.64.x.x] F=<*.*.com> temporarily rejected RCPT <*.*.com>: Could not complete sender verify
    2007-03-01 13:11:01 H=([192.168.1.120]) [75.64.x.x] sender verify defer for <*.*.com>: lowest numbered MX record points to local host
    2007-03-01 13:11:01 H=([192.168.1.120]) [75.64.x.x] F=<*.*.com> temporarily rejected RCPT <kientt@qsoft.com.vn>: Could not complete sender verify
    2007-03-01 13:11:07 H=([192.168.1.120]) [75.64.x.x] sender verify defer for <*.*.com>: lowest numbered MX record points to local host
    2007-03-01 13:11:07 H=([192.168.1.120]) [75.64.x.x] F=<*.*.com> temporarily rejected RCPT <*.*.com>: Could not complete sender verify
    2007-03-01 13:13:07 H=(nhanhoa08.nhanhoa.com) [70.85.224.202] F=<> temporarily rejected RCPT <nobody@x.x.x>: lowest numbered MX record points to local host
    2007-03-01 13:21:06 H=([192.168.1.120]) [75.64.x.x] sender verify defer for <*.*.com>: lowest numbered MX record points to local host
    2007-03-01 13:21:06 H=([192.168.1.120]) [75.64.x.x] F=<*.*.com> temporarily rejected RCPT <kientt@qsoft.com.vn>: Could not complete sender verify
    2007-03-01 13:21:13 H=([192.168.1.120]) [75.64.x.x] sender verify defer for <*.*.com>: lowest numbered MX record points to local host
    2007-03-01 13:21:13 H=([192.168.1.120]) [75.64.x.x] F=<*.*.com> temporarily rejected RCPT <*.*.com>: Could not complete sender verify

    I have also unchecked the exim configuration that verifies sender now and I am still having problems. Does anyone have any idea what this could be?

    :confused:
     
  2. jay1228

    jay1228 Member

    Joined:
    Apr 15, 2005
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    have you tried upgrading to latests CPanel version?
     
  3. problemsolver

    problemsolver Member

    Joined:
    Mar 1, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I tried that with zero luck. Any other ideas? :confused:
     
  4. sonjay

    sonjay Registered

    Joined:
    Aug 4, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Make sure the domain in question IS listed in /etc/localdomains and is NOT listed in /etc/remotedomains
     
  5. problemsolver

    problemsolver Member

    Joined:
    Mar 1, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Wow, that's truly amazing. I think that actually worked and the entire mail queue for the past 7 days has started being delivered. I have searched and search on this matter and this is the first time I feel confident in the 'fix'. What did changing around those files do, because the domain was not in the first one and it was in the second file.
     
  6. sonjay

    sonjay Registered

    Joined:
    Aug 4, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I'm not positive, exactly, but I just had another VPS set up for me with my hosting company, and the first domain I plopped on there was getting the same error messages you were. When I had the network engineer check into it, he told me that was the problem.

    Roughly, if the domain is listed in remotedomains and not listed in localdomains, the server thinks the e-mail should be going somewhere offsite, and I guess the server tries to relay it and fails. By switching that around, you're telling the server it's an onsite e-mail address, so the server delivers it internally instead of relaying.

    Anyway, glad I could help.
     
Loading...

Share This Page