The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail() putting IPv6 address into headers instead of IPv4 address, failing spam check

Discussion in 'E-mail Discussions' started by Robert Simpson, Jun 5, 2013.

  1. Robert Simpson

    Robert Simpson Registered

    Joined:
    Jun 8, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi folks,

    For some reason my PHP mail() is sending messages using the IPv6 address instead of IPv4 and it's causing Gmail and Hotmail to junk the messages.

    Any ideas as to how I can force it to send it using IPv4?


    Cheers,
    Robert

    PS. This is a bit on the urgent side so any help is greatly appreciated!

    - - - Updated - - -

    This is what it's giving me:

    Received: from [server domain] ([2a02:af8:1:1100::3950])
    by mx.google.com with ESMTPS id fs4si1805385wib.9.2013.06.04.08.59.10
    for <[my email]>
    (version=TLSv1 cipher=RC4-SHA bits=128/128);
    Tue, 04 Jun 2013 08:59:10 -0700 (PDT)
    Received-SPF: neutral (google.com: 2a02:af8:1:1100::3950 is neither permitted nor denied by best guess record for domain of nobody@[server domain]) client-ip=2a02:af8:1:1100::3950;
    Authentication-Results: mx.google.com;
    spf=neutral (google.com: 2a02:af8:1:1100::3950 is neither permitted nor denied by best guess record for domain of nobody@[server domain]) smtp.mail=nobody@[server domain]
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,784
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can try disabling IPV6 in Exim by browsing to:

    "WHM Home » Service Configuration » Exim Configuration Manager » Advanced Editor"

    Scroll down until you see "Add additional configuration setting" (it's just above Section: BEGINACL"). Then, select the following option from the drop-down menu:

    disable_ipv6

    Set the value to:

    true

    Scroll to the very bottom of the page, and click "Save".

    Thank you.
     
Loading...

Share This Page