The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Queue 3 day hold only

Discussion in 'E-mail Discussions' started by eglwolf, Feb 23, 2004.

Thread Status:
Not open for further replies.
  1. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    How can I get exim to only hold mail for 3 days instead of seven, and after three days it deletes it out of the queue??
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    In the /etc/exim.conf file, around line 200, there is a section that says:

    # This option cancels (removes) frozen messages that are older than a week.
    timeout_frozen_after = 7d

    Change it to what you want, then restart exim from shell for the changes to take effect.
    /etc/rc.d/init.d/exim restart

    You can also modify it with "Exim Configuration Editor" in WHM.
     
  3. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    For future readers on issues of mail getting stuck in the mail queue, here is a couple of other settings that CPanel filled me in on:

    Just go to exim configuration editor in whm, choose advanced mode, and in the first box add the following:

    timeout_frozen_after = 7d
    ignore_bounce_errors_after = 12h
    auto_thaw = 12h

    The timeout_frozen_after line is what kills things after 7 days, the ignore_bounce_errors_after 12h to timeout bounces faster (bounces that bounce are almost always from spam), and auto_thaw 12h to try to deliver every 12 hours (old messages may default to attempt delivery every week or longer, and messages are only deleted on delivery attempts, this makes sure delivery is attempted every 12 hours so messages can get deleted in a reasonable amount of time).

    Of course you could change the values to what ever you like.
     
  4. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    I like that one. Thanks
     
  5. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    I tried both suggestions for the
    timeout_frozen_after = 3d

    and still it is keeping them longer than 3 day, so now what do I do?
     
  6. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    The older ones don't get removed until the next mailing attempt which, based on settings, could be a couple days. When I changed mine, I found it took about 3 days for the older ones to be gone.

    You did restart exim from shell right?
     
  7. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    I restared from whm. And then the cleared out the mail queue, and let it build again and there is mail in there from 4days.
     
  8. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    Restarting exim from WHM doesn't work. It must not do the same thing. I had the same problem at first. Changed the time, restarted from WHM, found no change, spent days trying to find the right file to change, then somehow found a note about restarting from shell, and all was well.

    You need to log into shell as root, or a SU and change to root, then do:
    /etc/rc.d/init.d/exim restart

    That's when the changes will take effect.
     
  9. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    OK thanks I will try that and see if that works.
     
  10. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    You can also if you are on a RH or Mandrake box do:

    service exim restart

    :)

    Brenden
     
  11. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    well I have added this in the top box in exim configuration advanced: and No Joy :(

    timeout_frozen_after = 3d
    ignore_bounce_errors_after = 12h
    auto_thaw = 12h



    Any other ideas, what could be wrong?

    I have hundered of bounce emails sitting in my queue from days ago.
     
  12. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    I stumbled on this thread looking for why my queue doesn't seem to be clearing anymore. My timeout_frozen is set to 7d yet I have stuff in the queue that is 42 days old, many of which are obviously to unlikely addresses such as username@company.com.

    This hasn't been a problem in the past. I think the queue stopped purging itself around the time I updated to WHM 9.4.0 cPanel 9.4.1-S65 / RedHat 8.0 - WHM X v3.1.0, but am unsure.

    Any thoughts?
     
  13. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    Your just duplicating these entries.

    If you place these entries in the first box that great however if you scroll though the entire exim.conf file you will notice they appear again around the halfway mark in exim.conf. So your adding to the top box which adds these entires at the top of the exim.conf file but lower down they are overridden again because they appear again? :confused: This doesnt make a whole lot of sense to me. Whoever suggested this?

    The file is read from top to bottom not bottom to top. If it was read bottom to top you may have a working installation. Why dont you just modify exim.conf where the entries appear then restart Exim. Thats all you need to do
     
    #13 mr.wonderful, Jul 26, 2004
    Last edited: Jul 26, 2004
  14. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Because it gets overwritten! Duh! :rolleyes:
     
  15. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Don't dig up year old threads, especially when you're adding nothing to it.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page