The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail queue "connection refused" problem

Discussion in 'E-mail Discussions' started by sime, May 21, 2006.

  1. sime

    sime Active Member

    Joined:
    Oct 16, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    I have the following problem when trying to send email to forwarded addresses. For privacy, I have replaced my customer's domain with "problem.com.au".

    Code:
    Message 1Fhwqq-0006ce-U8 is not frozen
    delivering 1Fhwqq-0006ce-U8
    Connecting to mx03.iprimus.com.au [210.50.30.77]:25 ... failed: Connection refused
    LOG: MAIN
      mx03.iprimus.com.au [210.50.30.77]: Connection refused
    LOG: MAIN
      == desmond@iprimus.com.au <desmond@problem.com.au> R=lookuphost T=remote_smtp defer (111): Connection refused
    
    /var/log/exim_mainlog reflects the above.

    So, desmond@problem.com.au seems to be correctly forwarded to desmond@iprimus.com.au, but iprimus (an ISP) is rejecting it? Searching for this problem, it seems that DNS is usually the cause, but I have doubled checked the DNS for this domain and it is resolving correctly. I can ping and dig OK.

    My gut feeling is that iprimus is trying to determine whether this is a legitimate email and either it is being too nasty about it, or my server is not correctly identifying. Any help would be greatly appreciated.

    Simon
     
  2. kerriritter

    kerriritter Active Member

    Joined:
    Oct 25, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    You might need to contact them

    I have found if one of my servers gets a "Connection Refused" when trying to send mail, that is means my servers IP is blocked for some reason, possibly they think it is spam.

    I would write to Iprimus or go to their site and look for a form to submit to get your servers IP unblocked. It usually takes about 24 hours.
     
  3. sime

    sime Active Member

    Joined:
    Oct 16, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Thanks kerriritter

    I think you are right. Am following this line.

    So far the ISP are claiming I have to go straight to the blacklister. But that is crazy because I'm sure that I would have got a rejection from the blacklister rather than iprimus' own mail servers.

    I've got a bad feeling about this... :)
     
  4. sime

    sime Active Member

    Joined:
    Oct 16, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Just to follow up, yes looks like some sort of block. The ISP are claiming responsibility due to some new "SMTP gateway software" they are trialling.
     
Loading...

Share This Page