The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail Queue EVERYTHING is not frozen

Discussion in 'E-mail Discussions' started by XPerties, Mar 12, 2004.

  1. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA

    Every single e-mail gets caught up in mail Q. I have don't this at least 7 times:

    rm -f /usr/local/cpanel/cpanel
    /scripts/installgd
    /scripts/cleanmd5
    /scripts/upcp

    /scripts/exim4

    rebooted server (both servers) many times.

    checked /etc/resolv.conf


    Never had issues until after updating. This happens on 2 servers both running cPanel 9.1.0-S73

    DOES ANYONE have any clue what else I can do?

    cPanel.net Support Ticket Number: 42837
     
  2. VirtuaLira

    VirtuaLira Well-Known Member

    Joined:
    Feb 1, 2004
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    Hi man.

    I TRY TO SEND THE Q MAIL or EMAILS AND NOTHING HAPPEN!!! the emails don't go to the destinatary... uffff

    Any one fixed the Q mail problem???? I think that was fixed, but I try to send email to other people outside of my hosted domains... and NOTHING..... the emails get in Q and when I try to send the Q emails, says "COMPLETE"... but I load the queue again and all the emails appears again.... PLEASE HELP!!!! NEED TO FIX IPTABLES?????? or something?? please If one get all working FINE PLEASE LET US NOW!!!!

    :(
     
  3. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Going back up and staying up until someone from cpanel fixes this.
     
  4. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    after reading almost every dam thread here and ev1 forums and WHT forums putting these together and doing them in order seems all issues are all done. Don't ask me what did it, it just works now.

    Also I'm to dam tiered to credit people for this so here is what I did and thank you to those who I copied from:

    =====================================





    /scripts/updatenow
    ====================

    /scripts/exim4
    ====================

    /etc/rc.d/init.d/cpanel stop

    ====================

    rm -f /usr/local/cpanel/cpanel
    /scripts/installgd
    /scripts/cleanmd5
    /scripts/upcp

    ====================


    SSH into your server under root and run this

    iptables -L | more

    i found this line under chain OUTPUT

    target prot opt source destination ACCEPT tcp -- anywhere localhost tcp dpt:smtp REJECT tcp -- anywhere anywhere tcp dpt:smtp reject-

    to get rid of it i ran these commands

    iptables -D OUTPUT 2
    iptables -D OUTPUT 1

    emailed flowed correctly after that.

    ====================

    To forcibly attempt delivery on any mail in the queue, use
    exim -qf
     
  5. maxbia

    maxbia Active Member

    Joined:
    Feb 11, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Well good to see someone actually takes the time to come back to help others instead of being one of these idiots that just posts "fixed"
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Does everyone having a problem have the smtp security tweak turned on?>
     
  7. iisnet

    iisnet Active Member

    Joined:
    Oct 6, 2002
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    I have it turned on.

    cPanel.net Support Ticket Number: 42883, 42884
     
  8. iisnet

    iisnet Active Member

    Joined:
    Oct 6, 2002
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    If I turn it off, this error still persists.
     
  9. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Both of my servers that had this issue did have SMTP enabled. After doing the above everything seems to be working and SMTP is still enabled.

    You threw another feature in didn't you, and didn't test it?:mad:
     
  10. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    Well, this fix may work on Linux, but FREEBSD does not use IPTables. So now what? FREEBSD users are left behind.

    Thats one issue, now all images in WHM are broken?
    Now all machines that we upgraded have the DNS issue
    as others do.

    Bind reloading on host using ndc
    Error reloading bind on host: Reload initiated.

    Now what Nick?
     
  11. snelhost

    snelhost Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi I'm running RHEL3 and WHM 9.1.0 cPanel 9.1.0-S73.

    I'm experincing the same error, when I want to deliver a mail who is in the queue I get following error:
    -------
    Message 1B2AoB-00064K-W4 is not frozen
    -------

    So I did the following as sugested.
    iptables -D OUTPUT 2 gave me the following error:
    ------
    iptables: Index of deletion too big
    ------

    I still get the error of mail not frozen.

    Here is what my iptables look like right now: is there someting wrong with that?
    -------
    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    --------

    anyone have a clue how to fix that.
     
  12. bwwt

    bwwt Member

    Joined:
    Aug 13, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Awesome, mine is finally fixed. Before, I was unable to get sendmail to fire over emails to my hotmail account. Thanks to the creator of this thread email is now flowing correctly :)

    I had the same problem with the index being too big. If you have a firewall such as APF, just flush your tables entirely. Once I did that, everything went smoothly.
     
  13. snelhost

    snelhost Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    As apf was not yet installed, I just did, to be able to flush the tables.

    when I wanted to start the firewall with
    aps -s i get following error:
    ------
    Unable to load iptables module (ip_tables), aborting.
    ------

    I wanted to restart iptables:
    service iptables restart but
    Unloading iptables modules: Failed

    So I wanted to reinstall iptables with:
    scripts/installrpm iptables

    But like it is not my day today the redhat update site is ofline untill suday evening. (monday morning for me :()

    It that the way I have to go or is there an other solution to get back iptables working.
     
  14. woolly

    woolly Active Member

    Joined:
    Dec 29, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    i followed the instructions and the problem still isn't fixed :(
     
  15. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
    does the exim.pl file exsit in /etc ?
     
  16. networxhosting

    networxhosting Well-Known Member
    PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamilton, Ontario, CANADA
    I am having similar problems as well.

    I had to disable the SMTP Security tweak to make it function correctly. It appears that when its on, exim cannot connect to any mail servers to deliver mail. After further investigation i noticed that iptables is MISSING these chains (found from our other cpanel box with the tweak turned on and working fine:

    ACCEPT tcp -- anywhere anywhere tcp dpt:smtp OWNER GID match mail
    ACCEPT tcp -- anywhere anywhere tcp dpt:smtp OWNER GID match mailman
    ACCEPT tcp -- anywhere anywhere tcp dpt:smtp OWNER UID match root
     
  17. woolly

    woolly Active Member

    Joined:
    Dec 29, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    how do i make changes to the IP table?
     
  18. networxhosting

    networxhosting Well-Known Member
    PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamilton, Ontario, CANADA
    Im not sure the exact command or chain to use, but i just disabled iptables until a fix can be found

    service iptables stop
     
  19. snelhost

    snelhost Registered

    Joined:
    Feb 2, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    yes exim.pl and exim.pl.local does exist in /etc/
     
  20. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    I tried that whole thing the person posted...with iptables n all that.

    didn't work - using RHEL 3

    :eek:

    And it's really beginning to suck - I have 59 messages of mine in there that HAVE to get out soon. :(
     
Loading...

Share This Page