Mail queue isn't deleting older messages.

gflamerich

Well-Known Member
Jul 21, 2003
122
0
166
Hi
Since last week seems that mail queue isn't deleting older messages. We have our exim configured to delete messages older than 4 days, as default: F,2h,15m; G,16h,1h,1.5; F,4d,8h, but know we have messages with 7 and 8 days in queue.
We have checket at exim_mainlog and the messages are trying to be delivered so we figure mail queue is working fine.
 

nisse

Well-Known Member
Nov 11, 2003
87
0
156
What are your settings for ignore_bounce_errors_after and timeout_frozen_after?
 

jackie46

BANNED
Jul 25, 2005
536
0
166
nisse said:
What are your settings for ignore_bounce_errors_after and timeout_frozen_after?
Doesnt matter what its set to in exim.conf.

We have;

timeout_frozen_after = 2d
ignore_bounce_errors_after = 12h
auto_thaw = 3h

And none of this works.
 

gflamerich

Well-Known Member
Jul 21, 2003
122
0
166
Now it's deleting the older mails

Thanks for the posts,
We notice that newer messages (with 4 days) are being delete, so decide to manually delete the older ones (those with 7 and 8 days).
We have the default settings, and never changed.
 

rs-freddo

Well-Known Member
May 13, 2003
828
1
168
Australia
cPanel Access Level
Root Administrator
I had mine set to delete after 2 days and noticed it's keeping them on for the full 8 days now. Must have been a change in the exim configs...
 

rs-freddo

Well-Known Member
May 13, 2003
828
1
168
Australia
cPanel Access Level
Root Administrator
I use this code in the RETRY configuration box.
* refused F,2h,15m; G,16h,1h,1.5; F,36h,8h
* * F,2h,15m; G,16h,1h,1.5; F,2d,8h
Used to clear the queue after 2 days and doesn't work anymore.