The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mail queue isn't deleting older messages.

Discussion in 'E-mail Discussions' started by gflamerich, Oct 4, 2005.

  1. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Hi
    Since last week seems that mail queue isn't deleting older messages. We have our exim configured to delete messages older than 4 days, as default: F,2h,15m; G,16h,1h,1.5; F,4d,8h, but know we have messages with 7 and 8 days in queue.
    We have checket at exim_mainlog and the messages are trying to be delivered so we figure mail queue is working fine.
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    If you changed the maximum days to 4 recently, you may need to restart exim for the change to take effect.
     
  3. nisse

    nisse Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    What are your settings for ignore_bounce_errors_after and timeout_frozen_after?
     
  4. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Doesnt matter what its set to in exim.conf.

    We have;

    timeout_frozen_after = 2d
    ignore_bounce_errors_after = 12h
    auto_thaw = 3h

    And none of this works.
     
  5. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Now it's deleting the older mails

    Thanks for the posts,
    We notice that newer messages (with 4 days) are being delete, so decide to manually delete the older ones (those with 7 and 8 days).
    We have the default settings, and never changed.
     
  6. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I had mine set to delete after 2 days and noticed it's keeping them on for the full 8 days now. Must have been a change in the exim configs...
     
  7. sexshun

    sexshun Active Member

    Joined:
    Sep 28, 2005
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
  8. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I use this code in the RETRY configuration box.
    * refused F,2h,15m; G,16h,1h,1.5; F,36h,8h
    * * F,2h,15m; G,16h,1h,1.5; F,2d,8h
    Used to clear the queue after 2 days and doesn't work anymore.
     
Loading...

Share This Page