The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mail queue issue

Discussion in 'E-mail Discussions' started by chadi, Jul 31, 2004.

  1. chadi

    chadi BANNED

    Joined:
    Apr 20, 2004
    Messages:
    415
    Likes Received:
    0
    Trophy Points:
    0
    For some reason there are tons of non-spam mail in the mail queue (WHM) but they just still there no matter how many times I've did "attempt to deliver all mail" The server is not slagging and in good status all the way. What could cause this?

    Done:
    restareted exim
    installed apf
    installed bfd
    installed exiscan+clam

    Tested ougoing and incoming to our own email and works just fine. Strange.
     
  2. chadi

    chadi BANNED

    Joined:
    Apr 20, 2004
    Messages:
    415
    Likes Received:
    0
    Trophy Points:
    0
    "Delivering All Messages in Queue"

    That's about it.
     
  3. chadi

    chadi BANNED

    Joined:
    Apr 20, 2004
    Messages:
    415
    Likes Received:
    0
    Trophy Points:
    0
    There is 93 in queue right now. Is this normal? It shouldn't take this long.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Nothing wrong with a queue length of 93 - it all depends on the receiving SMTP server and how long it's been waiting. The longer it's been waiting, the less frequently the queue running checks it's status until it dies.

    Here's a handy guide that I've just thrown together for long mail queues:

    One thing to make sure if you start getting a huge mail queue (several thousand) is that:

    1. Exim (and MailScanner if you use it) is all up and running correctly - this means restarting it

    2. The emails aren't all from nobody or one particular user (otherwise you probably have a vulnerable script on your server)

    3. You don't have a demo account enabled - or if you do, you've implemented to exim.pl patch mentioned recently on these forums. Demo mode opens your server up as an open relay.

    4. You don't have mail users overquota

    Ways to mitigate such problems are:

    1. Never use demo mode

    2. Make sure that you have the WHM > Tweak Settings > "The maximum each domain can send out per hour" set to something sensible (not 0) like 500 or whatever you can settle on with your users

    3. That you enable WHM > Exim Configuration Editor > tick "Discard emails for users who have exceeded their quota instead of keeping them in the queue."

    4. If you have any anti-spam solution using exim ACL's, exiscan or MailScanner that you never send bounces back to the spammer!

    5. Be patient. Mail queues exist for a reason, to schedule email for delivery to remote SMTP servers that are temporarily unavailable. If it's not causing either a performance hit or slowing down mail delivery/receipt then leave it alone.
     
  5. erwinfa

    erwinfa Well-Known Member

    Joined:
    Jun 14, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    Is it possible to set quota email limitation that send through smtp server ? Sometimes there are users send more 50 MB a few times and bounch to queue. It make load server increase
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can set a per email maximum size with:

    message_size_limit = 5M

    That you would put in the first textarea of the WHM > Exim Configuration Editor > Advanced mode.
     
Loading...

Share This Page